]> git.pld-linux.org Git - packages/perl-Digest-Skein.git/blob - perl-Digest-Skein.spec
c15408d18e424899d8546900cf47544762cdacbf
[packages/perl-Digest-Skein.git] / perl-Digest-Skein.spec
1 #
2 # Conditional build:
3 %bcond_without  autodeps        # don't BR packages needed only for resolving deps
4 %bcond_without  tests           # do not perform "make test"
5 #
6 %define pdir    Digest
7 %define pnam    Skein
8 Summary:        Digest::Skein - Perl interface to the Skein digest algorithm
9 #Summary(pl.UTF-8):
10 Name:           perl-Digest-Skein
11 Version:        0.05
12 Release:        11
13 License:        GPL
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  cb7ff5208a078e5e504715e6486a06d5
17 URL:            http://search.cpan.org/dist/Digest-Skein/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with autodeps} || %{with tests}
21 BuildRequires:  perl(Digest)
22 BuildRequires:  perl(MIME::Base64)
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Digest::Skein implements the Skein digest algorithm, submitted to NIST
28 for the SHA-3 competition.
29
30 # %description -l pl.UTF-8
31 # TODO
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} pure_install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README TODO
57 %{perl_vendorarch}/Digest/*.pm
58 %dir %{perl_vendorarch}/auto/Digest/Skein
59 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/Skein/*.so
60 %{_mandir}/man3/*
61 #it should go to static subpackage, shouldn't it?
62 #%{perl_vendorarch}/auto/libskein/libskein.a
This page took 0.077278 seconds and 2 git commands to generate.