]> git.pld-linux.org Git - packages/perl-Digest-SHA.git/blob - perl-Digest-SHA.spec
685f535d5a0faa639a1aa16fe9e616fbe3d94b15
[packages/perl-Digest-SHA.git] / perl-Digest-SHA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Digest
7 %define         pnam    SHA
8 Summary:        Digest::SHA - interface to the SHA algorithm
9 Summary(pl.UTF-8):      Digest::SHA - interfejs do algorytmu SHA
10 Name:           perl-Digest-SHA
11 Version:        5.84
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  5e8a952b2728bac2a44caefc0abc9642
18 URL:            http://search.cpan.org/dist/Digest-SHA/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Digest::SHA is a complete implementation of the NIST Secure Hash
25 Standard. It gives Perl programmers a convenient way to calculate
26 SHA-1, SHA-224, SHA-256, SHA-384, and SHA-512 message digests.
27 The module can handle all types of input, including partial-byte
28 data.
29
30 %description -l pl.UTF-8
31 Digest::SHA to pełna implementacja standardu NIST Secure Hash.
32 Udostępnia programistom perlowym wygodny sposób obliczania skrótów
33 wiadomości SHA-1, SHA-224, SHA-256, SHA-384 i SHA-512. Ten moduł
34 potrafi obsłużyć wszelkie rodzaje wejścia, włącznie z danymi
35 składającymi się z części bajtów.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51 install -d $RPM_BUILD_ROOT%{perl_archlib}
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc README Changes
62 %attr(755,root,root) %{_bindir}/shasum
63 %{perl_vendorarch}/Digest/SHA.pm
64 %dir %{perl_vendorarch}/auto/Digest/SHA
65 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/SHA/SHA.so
66 %{_mandir}/man1/shasum.1p*
67 %{_mandir}/man3/Digest::SHA.3pm*
This page took 0.070172 seconds and 2 git commands to generate.