]> git.pld-linux.org Git - packages/perl-Digest-GOST.git/blob - perl-Digest-GOST.spec
rebuild with perl 5.32
[packages/perl-Digest-GOST.git] / perl-Digest-GOST.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Digest
6 %define         pnam    GOST
7 Summary:        Digest::GOST - Perl interface to the GOST R 34.11-94 digest algorithm
8 Summary(pl.UTF-8):      Digest::GOST - implementacja algorytmu skrótu GOST R 34.11-94
9 Name:           perl-Digest-GOST
10 Version:        0.06
11 Release:        7
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  d91904e56300d08956ea5f1e174863f3
17 URL:            http://search.cpan.org/dist/Digest-GOST/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-Test-Simple >= 0.82
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 The Digest::GOST module provides an interface to the GOST R 34.11-94
27 message digest algorithm. This interface follows the conventions set
28 forth by the Digest module. To use the CryptoPro parameters, use
29 Digest::GOST::CryptoPro.
30
31 %description -l pl.UTF-8
32 Moduł Digest::GOST implementuje algorytm skrótu GOST R 34.11-94.
33 Interfejs programistyczny jest zgodny z konwencją przyjętą przez
34 moduł Digest. W przypadku wykorzystywania parametrów CryptoPro
35 należy użyć modułu Digest::GOST::CryptoPro.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc README Changes
61 %{perl_vendorarch}/Digest/GOST.pm
62 %{perl_vendorarch}/Digest/GOST
63 %dir %{perl_vendorarch}/auto/Digest/GOST
64 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/GOST/GOST.so
65 %{_mandir}/man3/Digest::GOST.3pm*
66 %{_mandir}/man3/Digest::GOST::CryptoPro.3pm*
This page took 0.075814 seconds and 3 git commands to generate.