]> git.pld-linux.org Git - packages/perl-Digest-Elf.git/blob - perl-Digest-Elf.spec
688e05353b114d0c985295b1b4769cb6648c16e5
[packages/perl-Digest-Elf.git] / perl-Digest-Elf.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Digest
7 %define         pnam    Elf
8 Summary:        Digest::Elf - implementation of the ElfHash algorithm
9 Summary(pl.UTF-8):      Digest::Elf - implementacja algorytmu ElfHash
10 Name:           perl-Digest-Elf
11 Version:        1.4
12 Release:        7
13 License:        unknown
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  59e6737aae2f9efd1a8af8bc8655f575
17 URL:            http://search.cpan.org/dist/Digest-Elf/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Digest::Elf Perl module provides an implimentation of the ElfHash
24 algorithm.  ElfHash generates resonably unique values from a string in
25 a reasonably short period of time.  The actual algorith is culled from
26 a Dr. Dobbs Journal article, they culled it probably from the source
27 for the GNU C complier.
28
29 %description -l pl.UTF-8
30 Moduł Perla Digest::Elf jest implementacją algorytmu ElfHash. Algorytm
31 ten generuje w miarę unikalne wartości dla łańcuchów znaków w
32 przyzwoitym czasie. Właściwy algorytm jest ściągnięty z artykułu z Dr.
33 Dobbs Journal, gdzie został ściągnięty prawdopodobnie ze źródeł
34 kompilatora C z GNU.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/Digest/Elf.pm
61 %dir %{perl_vendorarch}/auto/Digest/Elf
62 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/Elf/Elf.so
63 %{_mandir}/man3/*
This page took 0.040541 seconds and 2 git commands to generate.