]> git.pld-linux.org Git - packages/perl-Digest-CRC.git/blob - perl-Digest-CRC.spec
bff520881ca4ba68b5a87fc59c9adb76815b62f0
[packages/perl-Digest-CRC.git] / perl-Digest-CRC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Digest
7 %define         pnam    CRC
8 Summary:        Digest::CRC - Generic CRC functions
9 Summary(pl.UTF-8):      Digest::CRC - podstawowe funkcje CRC
10 Name:           perl-Digest-CRC
11 Version:        0.18
12 Release:        6
13 License:        Public Domain
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Digest/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  baf8cb6c50782416b10f470b2e29bf7a
17 URL:            http://search.cpan.org/dist/Digest-CRC/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 The Digest::CRC module calculates CRC sums of all sorts. It contains
24 wrapper functions with the correct parameters for CRC-CCITT, CRC-16
25 and CRC-32.
26
27 %description -l pl.UTF-8
28 Moduł Digest::CRC oblicza różnego rodzaju sumy kontrolne CRC. Posiada
29 funkcje - wrappery z odpowiednimi parametrami dla CRC-CCITT, CRC-16
30 oraz CRC-32.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 %{__perl} Makefile.PL \
37         INSTALLDIRS=vendor
38
39 %{__make} \
40         CC="%{__cc}" \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorarch}/Digest/*.pm
58 %dir %{perl_vendorarch}/auto/Digest/CRC
59 %attr(755,root,root) %{perl_vendorarch}/auto/Digest/CRC/CRC.so
60 %{_mandir}/man3/*
This page took 0.043561 seconds and 2 git commands to generate.