]> git.pld-linux.org Git - packages/perl-Device-SerialPort.git/blob - perl-Device-SerialPort.spec
- release 9 (by relup.sh)
[packages/perl-Device-SerialPort.git] / perl-Device-SerialPort.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (uses serial port)
4
5 %define         pdir    Device
6 %define         pnam    SerialPort
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Device::SerialPort - Linux/POSIX emulation of Win32::SerialPort functions
9 Summary(pl.UTF-8):      Device::SerialPort - zgodna z POSIX emulacja funcji Win32::SerialPort w Linuksie
10 Name:           perl-Device-SerialPort
11 Version:        1.04
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  82c698151f934eb28c65d1838cee7d9e
18 URL:            http://search.cpan.org/dist/Device-SerialPort/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Device::SerialPort module provides an object-based user interface
25 essentially identical to the one provided by the Win32::SerialPort
26 module.
27
28 %description -l pl.UTF-8
29 Moduł Device::SerialPort udostępnia zorientowany obiektowo interfejs,
30 zasadniczo identyczny z interfejsem udostępnianym przez moduł
31 Win32::SerialPort.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 # hack device test
37 %{__perl} -pi -e 's/^    print "\\tchecking.*$/\$file="\$test"; last;/' Makefile.PL
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor \
42         TESTPORT="/dev/ttyS1"
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
54 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Change* README TODO
62 %attr(755,root,root) %{_bindir}/modemtest
63 %{perl_vendorarch}/Device/*.pm
64 %dir %{perl_vendorarch}/auto/Device/SerialPort
65 %attr(755,root,root) %{perl_vendorarch}/auto/Device/SerialPort/SerialPort.so
66 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
67 %{_mandir}/man[13]/*
This page took 0.078923 seconds and 3 git commands to generate.