]> git.pld-linux.org Git - packages/perl-Device-ParallelPort.git/blob - perl-Device-ParallelPort.spec
use generic url
[packages/perl-Device-ParallelPort.git] / perl-Device-ParallelPort.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %define         pdir    Device
6 %define         pnam    ParallelPort
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Device::ParallelPort - parallel port driver for Perl
9 Summary(pl.UTF-8):      Device::ParallelPort - sterownik portu równoległego dla Perla
10 Name:           perl-Device-ParallelPort
11 Version:        1.00
12 Release:        3
13 # same as perl (?)
14 # LICENSE says it is LGPL or Artistic
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  6d2345b31f9c3871230ba384c62c2d00
19 URL:            http://search.cpan.org/dist/Device-ParallelPort/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildArch:      noarch
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 A parallel port driver module. This module provides an API to all
27 parallel ports, by providing the ability to write any number of
28 drivers. Modules are available for Linux (both directly and via
29 parport), Win32 and a simple script version.
30
31 %description -l pl.UTF-8
32 Moduł sterownika portu równoległego. Ten moduł dostarcza API do
33 wszystkich portów równoległych, dając możliwość pisania dowolnej
34 liczby sterowników. Dostępne są moduły dla Linuksa (zarówno działający
35 bezpośrednio jak i przez parport), Win32 oraz prosta wersja skryptowa.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/Device/ParallelPort.pm
61 %dir %{perl_vendorlib}/Device/ParallelPort
62 %dir %{perl_vendorlib}/Device/ParallelPort/drv
63 %{perl_vendorlib}/Device/ParallelPort/*.pm
64 %{perl_vendorlib}/Device/ParallelPort/drv/*.pm
65 %{_mandir}/man3/*
This page took 0.114053 seconds and 3 git commands to generate.