]> git.pld-linux.org Git - packages/perl-Device-ParallelPort-drv-parport.git/blob - perl-Device-ParallelPort-drv-parport.spec
- rebuild with perl 5.30.0
[packages/perl-Device-ParallelPort-drv-parport.git] / perl-Device-ParallelPort-drv-parport.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %define         pdir    Device
6 %define         pnam    ParallelPort-drv-parport
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Device::ParallelPort - driver that uses direct I/O access
9 Summary(pl.UTF-8):      Device::ParallelPort - sterownik używający bezpośredniego wejścia/wyjścia
10 Name:           perl-Device-ParallelPort-drv-parport
11 Version:        1.0
12 Release:        14
13 # same as perl (?)
14 # README says it is Artistic only, LICENSE says it is LGPL or Artistic
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  901987e4a37bfe2d7241530bda05f36e
19 URL:            http://search.cpan.org/dist/Device-ParallelPort-drv-parport/
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Device-ParallelPort
24 %endif
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This is a Device::ParallelPort driver that uses direct I/O access on
29 Linux. It uses the Linux parport driver and is definitely the prefered
30 access method on Linux. It also means that you do not require root
31 access.
32
33 %description -l pl.UTF-8
34 To jest sterownik Device::ParallelPort używający bezpośredniego
35 dostępu do wejścia/wyjścia pod Linuksem. Korzysta z linuksowego
36 sterownika portu równoległego i jest preferowaną metodą dostępu na
37 Linuksie. Oznacza to także, że nie trzeba mieć praw roota.
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45
46 %{__make} \
47         OPTMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %dir %{perl_vendorarch}/Device/ParallelPort
64 %dir %{perl_vendorarch}/Device/ParallelPort/drv
65 %{perl_vendorarch}/Device/ParallelPort/drv/parport.pm
66 %dir %{perl_vendorarch}/auto/Device/ParallelPort
67 %dir %{perl_vendorarch}/auto/Device/ParallelPort/drv
68 %dir %{perl_vendorarch}/auto/Device/ParallelPort/drv/parport
69 %attr(755,root,root) %{perl_vendorarch}/auto/Device/ParallelPort/drv/parport/parport.so
70 %{_mandir}/man3/*
This page took 0.074563 seconds and 3 git commands to generate.