]> git.pld-linux.org Git - packages/perl-Device-ParallelPort-drv-parport.git/blob - perl-Device-ParallelPort-drv-parport.spec
2bb94763b93378e45d8039f91c75cfca0279bf39
[packages/perl-Device-ParallelPort-drv-parport.git] / perl-Device-ParallelPort-drv-parport.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4
5 %define         pdir    Device
6 %define         pnam    ParallelPort-drv-parport
7 Summary:        Device::ParallelPort - driver that uses direct I/O access
8 Summary(pl.UTF-8):      Device::ParallelPort - sterownik używający bezpośredniego wejścia/wyjścia
9 Name:           perl-Device-ParallelPort-drv-parport
10 Version:        1.0
11 Release:        14
12 # same as perl (?)
13 # README says it is Artistic only, LICENSE says it is LGPL or Artistic
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  901987e4a37bfe2d7241530bda05f36e
18 URL:            http://search.cpan.org/dist/Device-ParallelPort-drv-parport/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Device-ParallelPort
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This is a Device::ParallelPort driver that uses direct I/O access on
28 Linux. It uses the Linux parport driver and is definitely the prefered
29 access method on Linux. It also means that you do not require root
30 access.
31
32 %description -l pl.UTF-8
33 To jest sterownik Device::ParallelPort używający bezpośredniego
34 dostępu do wejścia/wyjścia pod Linuksem. Korzysta z linuksowego
35 sterownika portu równoległego i jest preferowaną metodą dostępu na
36 Linuksie. Oznacza to także, że nie trzeba mieć praw roota.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make} \
46         OPTMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %dir %{perl_vendorarch}/Device/ParallelPort
63 %dir %{perl_vendorarch}/Device/ParallelPort/drv
64 %{perl_vendorarch}/Device/ParallelPort/drv/parport.pm
65 %dir %{perl_vendorarch}/auto/Device/ParallelPort
66 %dir %{perl_vendorarch}/auto/Device/ParallelPort/drv
67 %dir %{perl_vendorarch}/auto/Device/ParallelPort/drv/parport
68 %attr(755,root,root) %{perl_vendorarch}/auto/Device/ParallelPort/drv/parport/parport.so
69 %{_mandir}/man3/*
This page took 0.080173 seconds and 2 git commands to generate.