]> git.pld-linux.org Git - packages/perl-Devel-Size.git/blob - perl-Devel-Size.spec
rebuild with perl 5.32
[packages/perl-Devel-Size.git] / perl-Devel-Size.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %define         pdir    Devel
6 %define         pnam    Size
7 Summary:        Devel::Size - finding the memory usage of Perl variables
8 Summary(pl.UTF-8):      Devel::Size - określanie zużycia pamięci przez zmienne Perla
9 Name:           perl-Devel-Size
10 Version:        0.82
11 Release:        3
12 # same as perl itself (as stated in COPYRIGHT section of pod)
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Devel/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  4d13a65774d06ff116c374d9a851a8b9
17 URL:            http://search.cpan.org/dist/Devel-Size/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module figures out the real sizes of Perl variables in bytes.
24 Call functions with a reference to the variable you want the size
25 of.  If the variable is a plain scalar it returns the size of
26 the scalar.  If the variable is a hash or an array, use a reference
27 when calling.
28
29 %description -l pl.UTF-8
30 Ten moduł oblicza prawdziwe rozmiary zmiennych perlowych w bajtach.
31 Wystarczy wywołać funkcję z referencją do zmiennej, której rozmiar
32 chce się poznać. Jeśli zmienna jest skalarem, zwraca rozmiar skalara.
33 Jeśli zmienna jest haszem lub tablicą, należy użyć referencji przy
34 wywołaniu.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc CHANGES
60 %{perl_vendorarch}/Devel/Size.pm
61 %dir %{perl_vendorarch}/auto/Devel/Size
62 %attr(755,root,root) %{perl_vendorarch}/auto/Devel/Size/Size.so
63 %{_mandir}/man3/Devel::Size.3pm*
This page took 0.068509 seconds and 3 git commands to generate.