]> git.pld-linux.org Git - packages/perl-Devel-ModInfo.git/blob - perl-Devel-ModInfo.spec
345ee94d2614dfa2c61b7bf597fe57090964aa7c
[packages/perl-Devel-ModInfo.git] / perl-Devel-ModInfo.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Devel
7 %define         pnam    ModInfo
8 Summary:        Devel::ModInfo - documenting system for Perl modules without creating runtime overhead
9 Summary(pl.UTF-8):      Devel::ModInfo - system dokumentacji modułów Perla bez narzutu w czasie wykonywania
10 Name:           perl-Devel-ModInfo
11 Version:        0.05
12 Release:        3
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  68b98713efba6de10af41bde55777b04
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 %if %{with tests}
20 BuildRequires:  perl-XML-DOM
21 BuildRequires:  perl-Parse-RecDescent
22 %endif
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 ModInfo is a system for documenting your Perl modules without creating
28 runtime overhead. Some of the concepts are based on the JavaBean
29 BeanInfo API, but the implementation is specific to Perl, and does not
30 require extra coding.
31
32 %description -l pl.UTF-8
33 ModInfo to system dokumentacji dla modułów Perla bez tworzenia narzutu
34 w czasie wykonywania. Niektóre idee są oparte na API JavaBean
35 BeanInfo, ale implementacja jest specyficzna dla Perla i nie wymaga
36 dodatkowego kodowania.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %attr(755,root,root) %{_bindir}/*
62 %{perl_vendorlib}/Devel/ModInfo.pm
63 %dir %{perl_vendorlib}/Devel/ModInfo
64 %{perl_vendorlib}/Devel/ModInfo/*.pm
65 %{perl_vendorlib}/Devel/ModInfo/ParamHash
66 %dir %{perl_vendorlib}/auto/Devel/ModInfo
67 %{perl_vendorlib}/auto/Devel/ModInfo/autosplit.ix
68 %{_mandir}/man[13]/*
This page took 0.455608 seconds and 2 git commands to generate.