]> git.pld-linux.org Git - packages/perl-Devel-Mallinfo.git/blob - perl-Devel-Mallinfo.spec
0dbc1859ae8acf245fa781da149989ebbf0197c6
[packages/perl-Devel-Mallinfo.git] / perl-Devel-Mallinfo.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Devel
7 %define         pnam    Mallinfo
8 Summary:        Devel::Mallinfo - mallinfo() memory statistics and more
9 Summary(pl.UTF-8):      Devel::Mallinfo - statystyki pamięci mallinfo()
10 Name:           perl-%{pdir}-%{pnam}
11 Version:        13
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  f3122dd6941edff1c469d3777b49edb5
18 URL:            http://search.cpan.org/dist/%{pdir}-%{pnam}/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Devel::Mallinfo is an interface to the C library mallinfo function
25 giving various totals for memory used by malloc. It's meant for
26 development use, to give you an idea how much memory your program and
27 libraries are using. Interfaces to some GNU C Library specific malloc
28 information are provided too, when available.
29
30 %description -l pl.UTF-8
31 Devel::Mallinfo jest interfejsem do funkcji mallinfo w bibliotece C,
32 służącej do tworzenia statystyk zajętości pamięci alokowane
33 przez malloc. Przeznaczony jest dla programistów, do zobrazowania ile
34 pamięci zajmuje program i biblioteki. Dostarczany jest również
35 interfejs do różnych informacji o zajętości pamięci
36 specyficznych dla biblioteki GNU C.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} pure_install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc README
65 %{perl_vendorarch}/%{pdir}/%{pnam}.pm
66 %dir %{perl_vendorarch}/auto/%{pdir}/%{pnam}
67 %attr(755,root,root) %{perl_vendorarch}/auto/%{pdir}/%{pnam}/%{pnam}.so
68 %{_mandir}/man3/*
69 %dir %{_examplesdir}/%{name}-%{version}/
70 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}/*
This page took 0.079066 seconds and 2 git commands to generate.