]> git.pld-linux.org Git - packages/perl-Devel-DebugInit.git/blob - perl-Devel-DebugInit.spec
use generic url
[packages/perl-Devel-DebugInit.git] / perl-Devel-DebugInit.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test"
4                         # fail on too deep recursion
5
6 %define         pdir    Devel
7 %define         pnam    DebugInit
8 %include        /usr/lib/rpm/macros.perl
9 Summary:        Creating a debugger initialization files from C header file macros
10 Summary(pl.UTF-8):      Tworzenie plików inicjalizacyjnych odpluskwiacza z makr nagłówków C
11 Name:           perl-Devel-DebugInit
12 Version:        0.3
13 Release:        13
14 # same as perl
15 License:        GPL or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  2a40f42bf194e4ef5250d6dd59fa00ed
19 URL:            http://search.cpan.org/dist/Devel-DebugInit/
20 BuildRequires:  perl-C-Scan
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildArch:      noarch
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 Devel::DebugInit is aimed at C/C++ developers who want access to C
28 macro definitions from within a debugger. It provides a simple and
29 automated way of creating debugger initialization files for a specific
30 project. The initialization files created contain user-defined
31 functions built from the macro definitions in the project's header
32 files.
33
34 %description -l pl.UTF-8
35 Moduł Devel::DebugInit ma służyć programistom C/C++, którzy chcą
36 dostać się do definicji makr C z poziomu odpluskwiacza. Moduł
37 udostępnia prosty i zautomatyzowany sposób tworzenia plików
38 inicjalizacyjnych odpluskwiacza dla danego projektu. Tworzone pliki
39 inicjalizacyjne zawierają podane przez użytkownika funkcje zbudowane z
40 definicji makr w plikach nagłówkowych projektu.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %{?with_tests:%{__make} test}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README TODO
64 %{perl_vendorlib}/Devel/DebugInit.pm
65 %{perl_vendorlib}/Devel/DebugInit
66 %{_mandir}/man3/*
This page took 0.046412 seconds and 3 git commands to generate.