]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
- release 3 (by relup.sh)
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # perform "make test"
4
5 %define         pdir    DateTime
6 %include        /usr/lib/rpm/macros.perl
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl.UTF-8):      DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        1.18
11 Release:        3
12 Epoch:          2
13 License:        Artistic 2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  58160bea9744a7bc9d7737f7dad9fa72
17 URL:            http://datetime.perl.org/
18 BuildRequires:  perl(Pod::Man) >= 1.14
19 BuildRequires:  perl-ExtUtils-CBuilder
20 BuildRequires:  perl-Module-Build >= 0.3601
21 BuildRequires:  perl-devel >= 1:5.8.1
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl(Time::Local) >= 1.04
25 BuildRequires:  perl-DateTime-Format-Strptime >= 1.2000
26 BuildRequires:  perl-DateTime-Locale >= 0.41
27 BuildRequires:  perl-DateTime-TimeZone >= 3:1.74
28 BuildRequires:  perl-Math-Round
29 BuildRequires:  perl-Params-Validate >= 0.76
30 BuildRequires:  perl-Test-Exception
31 BuildRequires:  perl-Test-Simple >= 0.88
32 %endif
33 Requires:       perl-base >= 1:5.8.7-3
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %description
37 DateTime is a class for the representation of date/time combinations,
38 and is part of the Perl DateTime project. For details on this project
39 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
40 which may help answer many "how do I do X?" questions. The FAQ is at
41 <http://datetime.perl.org/faq.html>.
42
43 %description -l pl.UTF-8
44 DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
45 częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
46 można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
47 swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
48 pod <http://datetime.perl.org/faq.html>.
49
50 %prep
51 %setup -q -n %{pdir}-%{version}
52
53 %build
54 %{__perl} Build.PL \
55         installdirs=vendor \
56         --config cc="%{__cc}" \
57         --config ld="%{__cc}" \
58         --config optimize="%{rpmcflags}"
59
60 ./Build
61
62 %{?with_tests:./Build test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 ./Build install \
68         destdir=$RPM_BUILD_ROOT
69
70 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/auto/DateTime/DateTime.bs
71
72 # for noarch DateTime::* modules
73 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc CREDITS Changes TODO leaptab.txt
81 %dir %{perl_vendorlib}/DateTime/Event
82 %dir %{perl_vendorlib}/DateTime/Format
83 %{perl_vendorarch}/DateTime.pm
84 %{perl_vendorarch}/DateTimePP.pm
85 %{perl_vendorarch}/DateTimePPExtra.pm
86 %{perl_vendorarch}/DateTime/*.pm
87 %dir %{perl_vendorarch}/auto/DateTime
88 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
89 %{_mandir}/man3/DateTime*.3pm*
This page took 0.060042 seconds and 3 git commands to generate.