]> git.pld-linux.org Git - packages/perl-DateTime.git/blob - perl-DateTime.spec
368572ec5bc9b36f667544916d9e071e314014b0
[packages/perl-DateTime.git] / perl-DateTime.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # perform "make test"
4 %bcond_with     tests_i18n      # tests with localization (requires some DateTime::Locale language resources)
5
6 %define         pdir    DateTime
7 Summary:        DateTime - representation of date/time combinations
8 Summary(pl.UTF-8):      DateTime - reprezentacja kombinacji daty i czasu
9 Name:           perl-DateTime
10 Version:        1.51
11 Release:        2
12 Epoch:          2
13 License:        Artistic v2.0
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{version}.tar.gz
16 # Source0-md5:  714843957118d9d24c4b4c9fc7efe8a5
17 URL:            http://datetime.perl.org/
18 BuildRequires:  perl(Pod::Man) >= 1.14
19 BuildRequires:  perl-Dist-CheckConflicts >= 0.02
20 BuildRequires:  perl-ExtUtils-CBuilder
21 BuildRequires:  perl-devel >= 1:5.8.4
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %if %{with tests}
24 BuildRequires:  perl-CPAN-Meta-Check >= 0.011
25 BuildRequires:  perl-CPAN-Meta-Requirements
26 BuildRequires:  perl-DateTime-Format-Mail >= 0.402
27 BuildRequires:  perl-DateTime-Format-Strptime >= 1.2000
28 BuildRequires:  perl-DateTime-Locale >= 1.06
29 BuildRequires:  perl-DateTime-TimeZone >= 3:2.02
30 BuildRequires:  perl-Math-Round
31 BuildRequires:  perl-Params-ValidationCompiler >= 0.26
32 BuildRequires:  perl-Scalar-List-Utils
33 BuildRequires:  perl-Specio >= 0.18
34 BuildRequires:  perl-Storable
35 BuildRequires:  perl-Test-Fatal
36 BuildRequires:  perl-Test-Simple >= 0.96
37 BuildRequires:  perl-Test-Warnings >= 0.005
38 BuildRequires:  perl-Try-Tiny
39 BuildRequires:  perl-namespace-autoclean >= 0.19
40 %endif
41 %if %{with tests_i18n} && "%(ls /usr/share/perl5/vendor_perl/auto/share/dist/DateTime-Locale/{de,en-US-POSIX,fr,it}.pl >/dev/null 2>&1 ; echo $?)" != "0"
42 BuildRequires:  perl-DateTime-Locale(with_locales:de;en-US;fr;it)
43 %endif
44 Requires:       perl-base >= 1:5.8.7-3
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %description
48 DateTime is a class for the representation of date/time combinations,
49 and is part of the Perl DateTime project. For details on this project
50 please see <http://datetime.perl.org/>. The DateTime site has a FAQ
51 which may help answer many "how do I do X?" questions. The FAQ is at
52 <http://datetime.perl.org/faq.html>.
53
54 %description -l pl.UTF-8
55 DateTime to klasa do reprezentowania kombinacji daty i czasu, będąca
56 częścią perlowego projektu DateTime. Szczegóły dotyczące tego projektu
57 można znaleźć pod adresem <http://datetime.perl.org/>. Serwis ten ma
58 swoje FAQ, gdzie można znaleźć odpowiedzi na wiele pytań - dostępne
59 pod <http://datetime.perl.org/faq.html>.
60
61 %prep
62 %setup -q -n %{pdir}-%{version}
63
64 %if %{with tests} && %{without tests_i18n}
65 %{__sed} -i -e "/^test_strftime_for_locale( '\(de\|it\)'/d" t/13strftime.t
66 %{__sed} -i -e "/locale.*'de'/ s/'de'/'en-US'/" t/23storable.t
67 %{__rm} t/14locale.t t/41cldr-format.t
68 %endif
69
70 %build
71 %{__perl} Makefile.PL \
72         INSTALLDIRS=vendor
73 %{__make}
74
75 %{?with_tests:%{__make} test}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79
80 %{__make} install \
81         DESTDIR=$RPM_BUILD_ROOT
82
83 # for noarch DateTime::* modules
84 install -d $RPM_BUILD_ROOT%{perl_vendorlib}/DateTime/{Event,Format}
85
86 %clean
87 rm -rf $RPM_BUILD_ROOT
88
89 %files
90 %defattr(644,root,root,755)
91 %doc CREDITS Changes TODO leaptab.txt
92 %dir %{perl_vendorlib}/DateTime/Event
93 %dir %{perl_vendorlib}/DateTime/Format
94 %{perl_vendorarch}/DateTime.pm
95 %{perl_vendorarch}/DateTime/*.pm
96 %dir %{perl_vendorarch}/auto/DateTime
97 %attr(755,root,root) %{perl_vendorarch}/auto/DateTime/DateTime.so
98 %{_mandir}/man3/DateTime*.3pm*
This page took 0.081458 seconds and 2 git commands to generate.