]> git.pld-linux.org Git - packages/perl-DateTime-Set.git/blob - perl-DateTime-Set.spec
- updated BRs
[packages/perl-DateTime-Set.git] / perl-DateTime-Set.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Set
8 Summary:        DateTime::Set - datetime sets and set math
9 Summary(pl.UTF-8):      DateTime::Set - zbiory czasów i matematyka na zbiorach
10 Name:           perl-DateTime-Set
11 Version:        0.3600
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8e98f70dc648bba7e9d91dd0e8d36b76
18 URL:            http://search.cpan.org/dist/DateTime-Set/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-DateTime >= 0.12
24 BuildRequires:  perl-DateTime-Locale
25 BuildRequires:  perl-DateTime-TimeZone
26 BuildRequires:  perl-Exporter-Tiny
27 BuildRequires:  perl-Module-Implementation
28 BuildRequires:  perl-Params-Validate
29 BuildRequires:  perl-Set-Infinite >= 0.59
30 %endif
31 BuildArch:      noarch
32 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
33
34 %description
35 DateTime::Set is a module for datetime sets. It can be used to handle
36 two different types of sets.
37
38 The first is a fixed set of predefined datetime objects. For example,
39 if we wanted to create a set of datetimes containing the birthdays of
40 people in our family.
41
42 The second type of set that it can handle is one based on the idea of
43 a recurrence, such as "every Wednesday", or "noon on the 15th day of
44 every month". This type of set can have fixed starting and ending
45 datetimes, but neither is required. So our "every Wednesday set" could
46 be "every Wednesday from the beginning of time until the end of time",
47 or "every Wednesday after 2003-03-05 until the end of time", or "every
48 Wednesday between 2003-03-05 and 2004-01-07".
49
50 %description -l pl.UTF-8
51 DateTime::Set to moduł do zbiorów czasów. Może być używany do obsługi
52 dwóch różnych rodzajów zbiorów.
53
54 Pierwszy to stały zbiór predefiniowanych obiektów czasu (datetime). Na
55 przykład jeśli chcemy stworzyć zbiór czasów zawierający urodziny osób
56 z naszej rodziny.
57
58 Drugi rodzaj zbiorów obsługiwany przez ten moduł jest oparty na idei
59 rekurencji, takiej jak "każda środa" lub "południe 15 dnia każdego
60 miesiąca". Ten rodzaj zbioru może mieć stałe czasy początkowe i
61 końcowe, ale żaden z nich nie jest wymagany. Tak więc "zbiór
62 wszystkich śród" może być "każdą środą od początku czasu do końca
63 czasu" lub "każdą środą po 2003-03-05 do końca czasu" lub "każdą środą
64 między 2003-03-05 a 2004-01-07".
65
66 %prep
67 %setup -q -n %{pdir}-%{pnam}-%{version}
68 %{__sed} -i -e 's/use Set::Infinite 0.5502/use Set::Infinite 0.55_02/' lib/Set/Infinite/_recurrence.pm
69
70 %build
71 %{__perl} Build.PL \
72         destdir=$RPM_BUILD_ROOT \
73         installdirs=vendor
74 ./Build
75
76 %{?with_tests:./Build test}
77
78 %install
79 rm -rf $RPM_BUILD_ROOT
80
81 ./Build install
82
83 %clean
84 rm -rf $RPM_BUILD_ROOT
85
86 %files
87 %defattr(644,root,root,755)
88 %doc Changes README TODO
89 %{perl_vendorlib}/DateTime/*.pm
90 %{perl_vendorlib}/Set/Infinite/_recurrence.pm
91 %{_mandir}/man3/*
This page took 0.115668 seconds and 3 git commands to generate.