]> git.pld-linux.org Git - packages/perl-DateTime-Set.git/blob - perl-DateTime-Set.spec
8a521b426ed36d04db832eb033221e7e9002fa7b
[packages/perl-DateTime-Set.git] / perl-DateTime-Set.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Set
8 Summary:        DateTime::Set - datetime sets and set math
9 Summary(pl.UTF-8):      DateTime::Set - zbiory czasów i matematyka na zbiorach
10 Name:           perl-DateTime-Set
11 Version:        0.3600
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  8e98f70dc648bba7e9d91dd0e8d36b76
18 URL:            http://search.cpan.org/dist/DateTime-Set/
19 BuildRequires:  perl-Module-Build
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-DateTime >= 0.12
24 BuildRequires:  perl-Set-Infinite >= 0.59
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 DateTime::Set is a module for datetime sets. It can be used to handle
31 two different types of sets.
32
33 The first is a fixed set of predefined datetime objects. For example,
34 if we wanted to create a set of datetimes containing the birthdays of
35 people in our family.
36
37 The second type of set that it can handle is one based on the idea of
38 a recurrence, such as "every Wednesday", or "noon on the 15th day of
39 every month". This type of set can have fixed starting and ending
40 datetimes, but neither is required. So our "every Wednesday set" could
41 be "every Wednesday from the beginning of time until the end of time",
42 or "every Wednesday after 2003-03-05 until the end of time", or "every
43 Wednesday between 2003-03-05 and 2004-01-07".
44
45 %description -l pl.UTF-8
46 DateTime::Set to moduł do zbiorów czasów. Może być używany do obsługi
47 dwóch różnych rodzajów zbiorów.
48
49 Pierwszy to stały zbiór predefiniowanych obiektów czasu (datetime). Na
50 przykład jeśli chcemy stworzyć zbiór czasów zawierający urodziny osób
51 z naszej rodziny.
52
53 Drugi rodzaj zbiorów obsługiwany przez ten moduł jest oparty na idei
54 rekurencji, takiej jak "każda środa" lub "południe 15 dnia każdego
55 miesiąca". Ten rodzaj zbioru może mieć stałe czasy początkowe i
56 końcowe, ale żaden z nich nie jest wymagany. Tak więc "zbiór
57 wszystkich śród" może być "każdą środą od początku czasu do końca
58 czasu" lub "każdą środą po 2003-03-05 do końca czasu" lub "każdą środą
59 między 2003-03-05 a 2004-01-07".
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63 %{__sed} -i -e 's/use Set::Infinite 0.5502/use Set::Infinite 0.55_02/' lib/Set/Infinite/_recurrence.pm
64
65 %build
66 %{__perl} Build.PL \
67         destdir=$RPM_BUILD_ROOT \
68         installdirs=vendor
69 ./Build
70
71 %{?with_tests:./Build test}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75
76 ./Build install
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc Changes README TODO
84 %{perl_vendorlib}/DateTime/*.pm
85 %{perl_vendorlib}/Set/Infinite/_recurrence.pm
86 %{_mandir}/man3/*
This page took 0.0356030000000001 seconds and 2 git commands to generate.