]> git.pld-linux.org Git - packages/perl-DateTime-Format-MySQL.git/blob - perl-DateTime-Format-MySQL.spec
254290e9fbb68a929854b68abdd27569b8e3626c
[packages/perl-DateTime-Format-MySQL.git] / perl-DateTime-Format-MySQL.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define pdir    DateTime
6 %define pnam    Format-MySQL
7 Summary:        DateTime::Format::MySQL - Parse and format MySQL dates and times
8 Summary(pl.UTF-8):      DateTime::Format::MySQL - analizowanie i formatowanie dat MySQL-a
9 Name:           perl-DateTime-Format-MySQL
10 Version:        0.06
11 Release:        1
12 # same as perl
13 License:        GPL v1+ or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/DateTime/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  60b84516b5f29e0c639cd1a0f12333d2
17 URL:            https://metacpan.org/release/DateTime-Format-MySQL
18 BuildRequires:  perl-Module-Build
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  rpmbuild(macros) >= 1.745
22 %if %{with tests}
23 BuildRequires:  perl-DateTime
24 BuildRequires:  perl-DateTime-Format-Builder >= 0.6
25 %endif
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 This module understands the formats used by MySQL for its DATE,
31 DATETIME, TIME and TIMESTAMP data types. It can be used to parse
32 these formats in order to create DateTime objects, and it can take a
33 DateTime object and produce a string representing it in the MySQL
34 format.
35
36 %description -l pl.UTF-8
37 Ten moduł rozumie formaty używane przez MySQL-a dla typów danych DATE,
38 DATETIME, TIME i TIMESTAMP. Może być używany do analizy tych formatów
39 w celu utworzenia obiektów DateTime; może także przyjąć obiekt
40 DateTime i utworzyć łańcuch z jego reprezentacją w formacie MySQL-a.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Build.PL \
47         destdir=$RPM_BUILD_ROOT \
48         installdirs=vendor
49 ./Build
50
51 %{?with_tests:./Build test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 ./Build install
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc Changes README
64 %{perl_vendorlib}/DateTime/Format/MySQL.pm
65 %{_mandir}/man3/DateTime::Format::MySQL.3pm*
This page took 0.038486 seconds and 2 git commands to generate.