]> git.pld-linux.org Git - packages/perl-DateTime-Event-Sunrise.git/blob - perl-DateTime-Event-Sunrise.spec
- initial, version 0.0505
[packages/perl-DateTime-Event-Sunrise.git] / perl-DateTime-Event-Sunrise.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define pdir    DateTime
7 %define pnam    Event-Sunrise
8 Summary:        DateTime::Event::Sunrise - Perl DateTime extension for computing the sunrise/sunset on a given day
9 Summary(pl.UTF-8):      DateTime::Event::Sunrise - moduł Perla do obliczania wschodów i zachodów Słońca
10 Name:           perl-DateTime-Event-Sunrise
11 Version:        0.0505
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  9aa0c4e005d6b8c985f1e9ae8d04047c
18 URL:            http://search.cpan.org/dist/DateTime-Event-Sunrise/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 This module will computes the time of sunrise and sunset for a given
26 date and a given location. The computation uses Paul Schlyter's
27 algorithm.
28 Actually, the module creates a DateTime::Event::Sunrise object or
29 a DateTime::Set object, which are used to generate the sunrise or
30 the sunset times for a given location and for any date.
31
32 %description -l pl.UTF-8
33 Ten moduł oblicza momenty wschodów i zachodów Słońca dla
34 podanej daty i lokalizacji. Obliczenia wykorzystują algorytm Paula
35 Schlytera. Moduł tworzy obiekty typu DateTime::Event::Sunrise lub
36 DateTime::Set.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorlib}/DateTime/Event/Sunrise.pm
61 %{_mandir}/man3/DateTime::Event::Sunrise.*
This page took 0.065858 seconds and 3 git commands to generate.