]> git.pld-linux.org Git - packages/perl-Date-Pcalc.git/blob - perl-Date-Pcalc.spec
- release 9 (by relup.sh)
[packages/perl-Date-Pcalc.git] / perl-Date-Pcalc.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Date
7 %define         pnam    Pcalc
8 Summary:        Date::Pcalc Perl module - Gregorian calendar date calculations
9 Summary(pl.UTF-8):      Moduł Perla Date::Pcalc - obliczenia na datach wg kalendarza gregoriańskiego
10 Name:           perl-Date-Pcalc
11 Version:        6.1
12 Release:        9
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  6a719d8fe10ac673be5d09e003130aa8
18 Patch0:         build.patch
19 URL:            http://catcode.com/date/pcalc.html
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 %if %{with tests}
23 BuildRequires:  perl-Bit-Vector >= 7.1
24 BuildRequires:  perl-Carp-Clan >= 5.3
25 %endif
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %define         _noautoreq      'perl(anything_fake_or_conditional)'
29
30 %description
31 This package consists of a Perl module for all kinds of date
32 calculations based on the Gregorian calendar (the one used in all
33 western countries today), thereby complying with all relevant norms
34 and standards: ISO/R 2015-1971, DIN 1355 and, to some extent, ISO 8601
35 (where applicable).
36
37 %description -l pl.UTF-8
38 Ten pakiet zawiera moduł Perla do wszystkich rodzajów obliczeń na
39 datach opartych na kalendarzu gregoriańskim (używanym aktualnie we
40 wszystkich państwach zachodnich) w sposób zgodny z odpowiednimi
41 normami i standardami: ISO/R 2015-1971, DIN 1355 i, w pewnym zakresie,
42 ISO 8601.
43
44 %prep
45 %setup -q -n %{pdir}-%{pnam}-%{version}
46 %patch0 -p1
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make} \
52         CC="%{__cc}" \
53         OPTIMIZE="%{rpmcflags}"
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
65 cp -a tools $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc CHANGES.txt CREDITS.txt INSTALL.txt README.txt EXAMPLES.txt
73 %dir %{perl_vendorarch}/Date
74 %{perl_vendorarch}/Date/Pcalc.pm
75 %dir %{perl_vendorarch}/Date/Pcalc
76 %{perl_vendorarch}/Date/Pcalc/Object.pm
77 %{perl_vendorarch}/Date/Pcalendar.pm
78 %dir %{perl_vendorarch}/Date/Pcalendar
79 %{perl_vendorarch}/Date/Pcalendar/*.pm
80 %dir %{perl_vendorarch}/auto/Date
81 %dir %{perl_vendorarch}/auto/Date/Pcalc
82 %attr(755,root,root) %{perl_vendorarch}/auto/Date/Pcalc/*.so
83 %{_mandir}/man3/*
84 %{_examplesdir}/%{name}-%{version}
This page took 0.123005 seconds and 3 git commands to generate.