]> git.pld-linux.org Git - packages/perl-Data-UUID.git/blob - perl-Data-UUID.spec
e545b82f5910137a018ede3bff30ef49b25bdeab
[packages/perl-Data-UUID.git] / perl-Data-UUID.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Data
7 %define         pnam    UUID
8 Summary:        Data::UUID - Perl extension for generating GUIDs/UUIDs
9 Summary(pl.UTF-8):      Data::UUID - rozszerzenie Perla do generowania GUID-ów/UUID-ów
10 Name:           perl-Data-UUID
11 Version:        1.221
12 Release:        1
13 License:        distributable
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  7619929e8fe205a7fb83bc1c29ecbf99
17 Patch0:         %{name}-types.patch
18 URL:            http://search.cpan.org/dist/Data-UUID/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module provides a framework for generating UUIDs (Universally
25 Unique Identifiers, also known as GUIDs (Globally Unique Identifiers).
26 A UUID is 128 bits long, and is guaranteed to be different from all
27 other UUIDs/GUIDs generated until 3400 A.D. UUIDs were originally used
28 in the Network Computing System (NCS) and later in the Open Software
29 Foundation's (OSF) Distributed Computing Environment. Currently many
30 different technologies rely on UUIDs to provide unique identity for
31 various software components.
32
33 %description -l pl.UTF-8
34 Moduł Perla Data::UUID udostępnia szkielet do generowania UUID-ów
35 (Universally Unique Identifiers - identyfikatorów unikalnych
36 powszechnie), znanych też jako GUID-y (Globally Unique Identifiers -
37 identyfikatory unikalne globalnie). UUID-y są 128-bitowe i
38 gwarantowana jest ich unikalność wśród wszyskich innych UUID-ów/
39 /GUID-ów wygenerowanych do roku 3400. UUID-y pierwotnie były używane w
40 Network Computing System (NCS), a później w Rozproszonym Środowisku
41 Obliczeniowym (Distributed Computing Environment) Fundacji Open
42 Software (OSF). Obecnie na zagwarantowanych przez UUID-y unikalnych
43 identyfikatorach dla różnych składników oprogramowania opartych jest
44 wiele różnych technologii
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48 %patch0 -p1
49
50 %build
51 %{__perl} Makefile.PL </dev/null \
52         INSTALLDIRS=vendor
53 %{__make} \
54         CC="%{__cc}" \
55         OPTIMIZE="%{rpmcflags}"
56
57 %{?with_tests:%{__make} test}
58
59 %install
60 rm -rf $RPM_BUILD_ROOT
61
62 %{__make} install \
63         DESTDIR=$RPM_BUILD_ROOT
64
65 %clean
66 rm -rf $RPM_BUILD_ROOT
67
68 %files
69 %defattr(644,root,root,755)
70 %doc Changes README
71 %{perl_vendorarch}/Data/UUID.pm
72 %dir %{perl_vendorarch}/auto/Data/UUID
73 %attr(755,root,root) %{perl_vendorarch}/auto/Data/UUID/UUID.so
74 %{_mandir}/man3/*
This page took 0.075062 seconds and 2 git commands to generate.