]> git.pld-linux.org Git - packages/perl-Data-UUID.git/blob - perl-Data-UUID.spec
7f742f71e922a7f9e86e52a016b3953fa5d52287
[packages/perl-Data-UUID.git] / perl-Data-UUID.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    UUID
7 Summary:        Data::UUID - Perl extension for generating GUIDs/UUIDs
8 Summary(pl.UTF-8):      Data::UUID - rozszerzenie Perla do generowania GUID-ów/UUID-ów
9 Name:           perl-Data-UUID
10 Version:        1.224
11 Release:        2
12 License:        distributable
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Data/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  71510bbcce760c394591fca83a9b5e6d
16 Patch0:         %{name}-types.patch
17 URL:            http://search.cpan.org/dist/Data-UUID/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module provides a framework for generating UUIDs (Universally
24 Unique Identifiers, also known as GUIDs (Globally Unique Identifiers).
25 A UUID is 128 bits long, and is guaranteed to be different from all
26 other UUIDs/GUIDs generated until 3400 A.D. UUIDs were originally used
27 in the Network Computing System (NCS) and later in the Open Software
28 Foundation's (OSF) Distributed Computing Environment. Currently many
29 different technologies rely on UUIDs to provide unique identity for
30 various software components.
31
32 %description -l pl.UTF-8
33 Moduł Perla Data::UUID udostępnia szkielet do generowania UUID-ów
34 (Universally Unique Identifiers - identyfikatorów unikalnych
35 powszechnie), znanych też jako GUID-y (Globally Unique Identifiers -
36 identyfikatory unikalne globalnie). UUID-y są 128-bitowe i
37 gwarantowana jest ich unikalność wśród wszyskich innych UUID-ów/
38 /GUID-ów wygenerowanych do roku 3400. UUID-y pierwotnie były używane w
39 Network Computing System (NCS), a później w Rozproszonym Środowisku
40 Obliczeniowym (Distributed Computing Environment) Fundacji Open
41 Software (OSF). Obecnie na zagwarantowanych przez UUID-y unikalnych
42 identyfikatorach dla różnych składników oprogramowania opartych jest
43 wiele różnych technologii
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47 %patch0 -p1
48
49 %build
50 %{__perl} Makefile.PL </dev/null \
51         INSTALLDIRS=vendor
52 %{__make} \
53         CC="%{__cc}" \
54         OPTIMIZE="%{rpmcflags}"
55
56 %{?with_tests:%{__make} test}
57
58 %install
59 rm -rf $RPM_BUILD_ROOT
60
61 %{__make} install \
62         DESTDIR=$RPM_BUILD_ROOT
63
64 %clean
65 rm -rf $RPM_BUILD_ROOT
66
67 %files
68 %defattr(644,root,root,755)
69 %doc Changes README
70 %{perl_vendorarch}/Data/UUID.pm
71 %dir %{perl_vendorarch}/auto/Data/UUID
72 %attr(755,root,root) %{perl_vendorarch}/auto/Data/UUID/UUID.so
73 %{_mandir}/man3/*
This page took 0.070883 seconds and 2 git commands to generate.