]> git.pld-linux.org Git - packages/perl-Data-Printer.git/blob - perl-Data-Printer.spec
f749ae66688973b1d41bf18695e0503942cb4a1c
[packages/perl-Data-Printer.git] / perl-Data-Printer.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 #
5 %define         pdir    Data
6 %define         pnam    Printer
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Data::Printer - colored pretty-print of Perl data structures and objects
9 #Summary(pl.UTF-8):     
10 Name:           perl-Data-Printer
11 Version:        0.35
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-authors/id/G/GA/GARU/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  621fde4207475fce3089a58d14c8e5c3
18 URL:            http://search.cpan.org/dist/Data-Printer/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Clone::PP)
23 BuildRequires:  perl(File::HomeDir) >= 0.91
24 BuildRequires:  perl(Sort::Naturally)
25 BuildRequires:  perl-Package-Stash >= 0.3
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 Colored pretty-print of Perl data structures and objects.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make}
40
41 %{?with_tests:%{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} pure_install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
50 cp -a examples $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes README
58 %{perl_vendorlib}/DDP.pm
59 %{perl_vendorlib}/Data/*.pm
60 %{perl_vendorlib}/Data/Printer
61 %{_mandir}/man3/*
62 %{_examplesdir}/%{name}-%{version}
This page took 0.055219 seconds and 2 git commands to generate.