]> git.pld-linux.org Git - packages/perl-Data-HexDump.git/blob - perl-Data-HexDump.spec
99f272a5c9d6b0075dec2172fda9d9f890f5285f
[packages/perl-Data-HexDump.git] / perl-Data-HexDump.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Data
7 %define         pnam    HexDump
8 Summary:        Data::HexDump - a simple hexadecial dumper
9 Summary(pl.UTF-8):      Data::HexDump - proste zrzucanie danych w formacie szesnastkowym
10 Name:           perl-Data-HexDump
11 Version:        0.02
12 Release:        4
13 # sa,e as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  467b7183d1062ab4a502b50c34e7d67f
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Dump in hexadecimal the content of a scalar. The result is returned in
25 a string. Each line of the result consists of the offset in the source
26 in the leftmost column of each line, followed by one or more columns
27 of data from the source in hexadecimal. The rightmost column of each
28 line shows the printable characters (all others are shown as single
29 dots).
30
31 %description -l pl.UTF-8
32 Data::HexDump wyrzuca szesnastkowo zawartość skalara. Wynik jest
33 zwracany jako łańcuch. Każda linia wyniku składa się z offsetu w
34 źródle w lewej kolumnie każdej linii, po którym następuje jedna lub
35 więcej kolumn szesnastkowych danych ze źródła. Prawa kolumna każdej
36 linii pokazuje znaki drukowalne (wszystkie inne są pokazywane jako
37 pojedyncze kropki).
38
39 %prep
40 %setup -q -n %{pdir}-%{pnam}-%{version}
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make}
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
55 mv $RPM_BUILD_ROOT%{_bindir}/hexdump $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc README
63 %{perl_vendorlib}/Data/*.pm
64 %{_mandir}/man3/*
65 %dir %{_examplesdir}/%{name}-%{version}
66 %{_examplesdir}/%{name}-%{version}/hexdump
This page took 0.044048 seconds and 2 git commands to generate.