]> git.pld-linux.org Git - packages/perl-Data-HexDump.git/blob - perl-Data-HexDump.spec
use generic url
[packages/perl-Data-HexDump.git] / perl-Data-HexDump.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Data
6 %define         pnam    HexDump
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Data::HexDump - a simple hexadecial dumper
9 Summary(pl.UTF-8):      Data::HexDump - proste zrzucanie danych w formacie szesnastkowym
10 Name:           perl-Data-HexDump
11 Version:        0.02
12 Release:        4
13 # sa,e as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  467b7183d1062ab4a502b50c34e7d67f
18 URL:            http://search.cpan.org/dist/Data-HexDump/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 Dump in hexadecimal the content of a scalar. The result is returned in
26 a string. Each line of the result consists of the offset in the source
27 in the leftmost column of each line, followed by one or more columns
28 of data from the source in hexadecimal. The rightmost column of each
29 line shows the printable characters (all others are shown as single
30 dots).
31
32 %description -l pl.UTF-8
33 Data::HexDump wyrzuca szesnastkowo zawartość skalara. Wynik jest
34 zwracany jako łańcuch. Każda linia wyniku składa się z offsetu w
35 źródle w lewej kolumnie każdej linii, po którym następuje jedna lub
36 więcej kolumn szesnastkowych danych ze źródła. Prawa kolumna każdej
37 linii pokazuje znaki drukowalne (wszystkie inne są pokazywane jako
38 pojedyncze kropki).
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 mv $RPM_BUILD_ROOT%{_bindir}/hexdump $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57
58 %clean
59 rm -rf $RPM_BUILD_ROOT
60
61 %files
62 %defattr(644,root,root,755)
63 %doc README
64 %{perl_vendorlib}/Data/*.pm
65 %{_mandir}/man3/*
66 %dir %{_examplesdir}/%{name}-%{version}
67 %{_examplesdir}/%{name}-%{version}/hexdump
This page took 0.055689 seconds and 3 git commands to generate.