]> git.pld-linux.org Git - packages/perl-DNS-Config.git/blob - perl-DNS-Config.spec
use generic url
[packages/perl-DNS-Config.git] / perl-DNS-Config.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4
5 %define pdir    DNS
6 %define pnam    Config
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DNS::Config - DNS Configuration
9 Summary(pl.UTF-8):      DNS::Config - konfiguracja DNS
10 Name:           perl-DNS-Config
11 Version:        0.66
12 Release:        2
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  71309d67930fe356c860bbb96289c0d4
18 URL:            http://search.cpan.org/dist/DNS-Config/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 A domain name service daemon configuration knows about the zone
26 information actively provided to the service users as well as lots of
27 other configuration data.
28
29 This class allows to represent this configuration data in a more or
30 less generic way. Another class, the file adaptor, then knows how to
31 write the information to a file in a daemon specific format.
32
33 %description -l pl.UTF-8
34 Konfiguracja demona usługi nazw domen (DNS) zawiera informacje o
35 strefach aktywnie dostarczanych użytkownikom usługi, a także wiele
36 innych danych konfiguracyjnych.
37
38 Ta klasa umożliwia reprezentowanie danych konfiguracyjnych w bardziej
39 lub mniej ogólny sposób. Inna klasa - adapter plików - ma informacje
40 dotyczące sposobu zapisu tych informacji w plikach w sposób właściwy
41 dla danego demona.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"%{pdir}::%{pnam}")' \
48         INSTALLDIRS=vendor
49 %{__make}
50
51 %{?with_tests:%{__make} test}
52
53 %install
54 rm -rf $RPM_BUILD_ROOT
55
56 %{__make} install \
57         DESTDIR=$RPM_BUILD_ROOT
58
59 %clean
60 rm -rf $RPM_BUILD_ROOT
61
62 %files
63 %defattr(644,root,root,755)
64 %doc docs/* README
65 %{perl_vendorlib}/DNS/*.pm
66 %{perl_vendorlib}/DNS/Config
67 %{_mandir}/man3/*
This page took 0.076458 seconds and 3 git commands to generate.