]> git.pld-linux.org Git - packages/perl-DBIx-TextIndex.git/blob - perl-DBIx-TextIndex.spec
- release 7 (by relup.sh)
[packages/perl-DBIx-TextIndex.git] / perl-DBIx-TextIndex.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires configured local MySQL database)
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBIx
7 %define         pnam    TextIndex
8 Summary:        DBIx::TextIndex - Perl extension for full-text searching in SQL databases
9 Summary(pl.UTF-8):      DBIx::TextIndex - rozszerzenie do pełnotekstowego przeszukiwania baz SQL
10 Name:           perl-DBIx-TextIndex
11 Version:        0.28
12 Release:        7
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBIx/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  1533f1e0c736988b22b29bcd4ba739a8
18 URL:            http://search.cpan.org/dist/DBIx-TextIndex/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl(Data::Dumper)
23 BuildRequires:  perl-Bit-Vector
24 BuildRequires:  perl-Exception-Class
25 BuildRequires:  perl-Text-Balanced
26 BuildRequires:  perl-Text-Unaccent
27 %endif
28 Requires:       perl-DBI >= 1.48-2
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DBIx::TextIndex was developed for doing full-text searches on BLOB
33 columns stored in a database. Almost any database with BLOB and DBI
34 support should work with minor adjustments to SQL statements in the
35 module.
36
37 %description -l pl.UTF-8
38 Moduł DBIx::TextIndex służy do przeprowadzania pełnotekstowych
39 przeszukiwań kolumn BLOB zapisanych w bazie danych. Prawie każda baza
40 danych z obsługą BLOB i DBI powinna działać po niewielkich poprawkach
41 wyrażeń SQL w module.
42
43 %prep
44 %setup -q -n %{pdir}-%{pnam}-%{version}
45
46 %build
47 %{__perl} Makefile.PL \
48         INSTALLDIRS=vendor
49 %{__make} \
50         CC="%{__cc}" \
51         OPTIMIZE="%{rpmcflags}"
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} pure_install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 gzip -9nf eg/README
63 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
64 rm -f $RPM_BUILD_ROOT%{perl_vendorarch}/auto/DBIx/TextIndex/.packlist
65
66 %clean
67 rm -rf $RPM_BUILD_ROOT
68
69 %files
70 %defattr(644,root,root,755)
71 %{perl_vendorarch}/DBIx/*.pm
72 %{perl_vendorarch}/DBIx/TextIndex
73 %dir %{perl_vendorarch}/auto/DBIx/TextIndex
74 %attr(755,root,root) %{perl_vendorarch}/auto/DBIx/TextIndex/*.so
75 %{_examplesdir}/%{name}-%{version}
76 %{_mandir}/man3/*
This page took 0.062407 seconds and 3 git commands to generate.