]> git.pld-linux.org Git - packages/perl-DBIx-TableHash.git/blob - perl-DBIx-TableHash.spec
use generic url
[packages/perl-DBIx-TableHash.git] / perl-DBIx-TableHash.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    DBIx
6 %define         pnam    TableHash
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DBIx::TableHash - Tie a hash to a MySQL table + SQL utils
9 Summary(pl.UTF-8):      DBIx::TableHash - powiązanie hasza z tabelą MySQL oraz narzędzia SQL
10 Name:           perl-DBIx-TableHash
11 Version:        1.04
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  83106f75a33d37b0685ded08322711ba
18 URL:            http://search.cpan.org/dist/DBIx-TableHash/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DBI
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 The DBHash object is designed to tie a hash to a table or a subset of
29 records in a table in a DBI database (only tested with MySQL in the
30 current version, but expected to work with any vendor).
31
32 %description -l pl.UTF-8
33 Obiekt DBHash służy do powiązania hasza z tabelą lub podzbiorem
34 rekordów w tabeli w bazie danych DBI (testowane tylko z aktualną
35 wersją MySQL, ale powinno działać z każdą bazą).
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make}
44
45 %{?with_tests:%{__make} test}
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %clean
54 rm -rf $RPM_BUILD_ROOT
55
56 %files
57 %defattr(644,root,root,755)
58 %{perl_vendorlib}/%{pdir}/*.pm
59 %{_mandir}/man3/*
This page took 0.054405 seconds and 3 git commands to generate.