]> git.pld-linux.org Git - packages/perl-DBIx-SQLEngine.git/blob - perl-DBIx-SQLEngine.spec
use generic url
[packages/perl-DBIx-SQLEngine.git] / perl-DBIx-SQLEngine.spec
1 #
2 # Conditional build:
3 %bcond_with     tests   # perform "make test" (requires working DBI connection)
4
5 %define         pdir    DBIx
6 %define         pnam    SQLEngine
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DBIx::SQLEngine - extends DBI with high-level operations
9 Summary(pl.UTF-8):      DBIx::SQLEngine - rozszerzenie DBI o wysokopoziomowe operacje
10 Name:           perl-DBIx-SQLEngine
11 Version:        0.93
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  963f4e41b77f7a1f6287eeac760a94e1
18 URL:            http://search.cpan.org/dist/DBIx-SQLEngine/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-Class-MakeMethods >= 1.003
23 BuildRequires:  perl-Class-MakeMethods-Template >= 1.003
24 BuildRequires:  perl-DBI >= 1.0
25 BuildRequires:  perl-DBIx-AnyDBD >= 2.0
26 %endif
27 BuildArch:      noarch
28 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
29
30 %description
31 The DBIx::SQLEngine class provides an extended interface for the DBI
32 database interface, adding methods that support ad-hoc SQL generation
33 and query execution in a single call.
34
35 %description -l pl.UTF-8
36 Klasa DBIx::SQLEngine udostępnia rozszerzony interfejs dla interfejsu
37 bazodanowego DBI, dodając metody obsługujące generowanie SQL w locie i
38 wykonywanie zapytań w pojedynczym wywołaniu.
39
40 %prep
41 %setup -q -n %{pdir}-%{pnam}-%{version}
42
43 %build
44 %{__perl} Makefile.PL \
45         INSTALLDIRS=vendor
46 %{__make}
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %{perl_vendorlib}/DBIx/*.pm
62 %dir %{perl_vendorlib}/DBIx/SQLEngine
63 %{perl_vendorlib}/DBIx/SQLEngine/*.pm
64 %{perl_vendorlib}/DBIx/SQLEngine/Cache
65 %{perl_vendorlib}/DBIx/SQLEngine/Criteria
66 %{perl_vendorlib}/DBIx/SQLEngine/Driver
67 %{perl_vendorlib}/DBIx/SQLEngine/Record
68 %{perl_vendorlib}/DBIx/SQLEngine/RecordSet
69 %{perl_vendorlib}/DBIx/SQLEngine/Schema
70 %{perl_vendorlib}/DBIx/SQLEngine/Utility
71 %{_mandir}/man3/*
This page took 0.047866 seconds and 3 git commands to generate.