]> git.pld-linux.org Git - packages/perl-DBIx-DataLookup.git/blob - perl-DBIx-DataLookup.spec
- drop obsolete and outdated manual inclusion of rpm macros
[packages/perl-DBIx-DataLookup.git] / perl-DBIx-DataLookup.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4
5 %define         pdir    DBIx
6 %define         pnam    DataLookup
7 Summary:        DataLookup - Perl extension for database view lookup table
8 Summary(pl.UTF-8):      DataLookup - rozszerzenie Perla do przeglądania widoków baz danych
9 Name:           perl-DBIx-DataLookup
10 Version:        0.03
11 Release:        5
12 License:        GPL v1+ or Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  fe4102aa940282b3fe731d37149b73dc
16 URL:            http://search.cpan.org/dist/DBIx-DataLookup/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildArch:      noarch
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Remotely similar to DBIx::Cache but is very simpler and serves
24 narrower purpose. This module allows you to both cache records pulled
25 by an SQL statement from a database in the memory as well as look them
26 up later at any time during execution of your script.
27
28 %description -l pl.UTF-8
29 Ten moduł zewnętrznie jest podobny do DBIx::Cache, ale jest prostszy i
30 ma węższy zakres zastosowań. Pozwala na pamiętanie w pamięci rekordów
31 wyciągniętych z bazy przez wyrażenia SQL, a także przeglądanie ich
32 później w dowolnej chwili.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}/%{pnam}
36
37 %build
38 %{__perl} -MExtUtils::MakeMaker -e 'WriteMakefile(NAME=>"DBIx::DataLookup")' \
39         INSTALLDIRS=vendor
40 %{__make}
41
42 %{?with_tests:%{__make} test}
43
44 %install
45 rm -rf $RPM_BUILD_ROOT
46
47 %{__make} install \
48         DESTDIR=$RPM_BUILD_ROOT
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %files
54 %defattr(644,root,root,755)
55 %{perl_vendorlib}/%{pdir}/*.pm
56 %{_mandir}/man3/*
This page took 0.062186 seconds and 3 git commands to generate.