]> git.pld-linux.org Git - packages/perl-DBIx-Cursor.git/blob - perl-DBIx-Cursor.spec
use generic url
[packages/perl-DBIx-Cursor.git] / perl-DBIx-Cursor.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    DBIx
6 %define         pnam    Cursor
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DBIx::Cursor - Perl extension for easy DBI-access to a single table
9 Summary(pl.UTF-8):      DBIx::Cursor - rozszerzenie do łatwego dostępu DBI do pojedynczych tabel
10 Name:           perl-DBIx-Cursor
11 Version:        0.14
12 Release:        4
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  80d518eafb9854b4a31d9a4c658c6af8
18 URL:            http://search.cpan.org/dist/DBIx-Cursor/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildArch:      noarch
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 The class DBIx::Cursor represents a cursor for a single
26 Database-table. You can select, update, insert or delete entries in a
27 table easier than creating SQL-statements. It does not use any
28 specific features of any database, so it should work with every
29 DBD-driver.
30
31 %description -l pl.UTF-8
32 Klasa DBIx::Cursor reprezentuje kursor dla pojedynczej tabeli bazy
33 danych. Można wykonywać operacje select, update, insert, delete na
34 elementach w tabeli łatwiej od tworzenia wyrażeń SQL. Moduł nie używa
35 żadnych cech specyficznych dla danej bazy, więc powinien działać z
36 każdym sterownikiem DBD.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make}
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %{perl_vendorlib}/%{pdir}/*.pm
60 %{_mandir}/man3/*
This page took 0.162026 seconds and 3 git commands to generate.