]> git.pld-linux.org Git - packages/perl-DBD-mysqlPP.git/blob - perl-DBD-mysqlPP.spec
use generic url
[packages/perl-DBD-mysqlPP.git] / perl-DBD-mysqlPP.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    DBD
6 %define         pnam    mysqlPP
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        DBD::mysqlPP - pure Perl MySQL driver for the DBI
9 Summary(pl.UTF-8):      DBD::mysqlPP - czysto perlowy sterownik do MySQL-a dla DBI
10 Name:           perl-DBD-mysqlPP
11 Version:        0.07
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  a259806d4c82e486fb474d8b5c15e6dd
18 URL:            http://search.cpan.org/dist/DBD-mysqlPP/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DBI >= 1.0
23 BuildRequires:  perl-Net-MySQL >= 0.08
24 %endif
25 Requires:       perl-Net-MySQL >= 0.08
26 BuildArch:      noarch
27 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
28
29 %description
30 DBD::mysqlPP is a Pure Perl MySQL driver for the Perl5 Database
31 Interface (DBI). This module implements network protool between server
32 and client of MySQL, thus you don't need external MySQL client library
33 like libmysqlclient for this module to work. It means this module
34 enables you to connect to MySQL server from some operation systems
35 which MySQL is not ported.
36
37 %description -l pl.UTF-8
38 DBD::mysqlPP to czysto perlowy sterownik do MySQL-a dla DBI (perlowego
39 interfejsu do baz danych). Ten moduł jest implementacją protokołu
40 sieciowego między serwerem a klientem MySQL-a, przez co nie wymaga do
41 działania zewnętrznej biblioteki klienckiej MySQL-a, takiej jak
42 libmysqlclient. Oznacza to, że moduł ten umożliwia połączenie z
43 serwerem MySQL nawet z systemu operacyjnego, na który MySQL nie został
44 sportowany.
45
46 %prep
47 %setup -q -n %{pdir}-%{pnam}-%{version}
48
49 %build
50 %{__perl} Makefile.PL \
51         INSTALLDIRS=vendor
52
53 %{__make}
54
55 %{?with_tests:%{__make} test}
56
57 %install
58 rm -rf $RPM_BUILD_ROOT
59
60 %{__make} install \
61         DESTDIR=$RPM_BUILD_ROOT
62
63 %clean
64 rm -rf $RPM_BUILD_ROOT
65
66 %files
67 %defattr(644,root,root,755)
68 %doc Changes README
69 %{perl_vendorlib}/DBD/mysqlPP.pm
70 %{_mandir}/man3/*
This page took 0.091696 seconds and 3 git commands to generate.