]> git.pld-linux.org Git - packages/perl-DBD-XBase.git/blob - perl-DBD-XBase.spec
- up to 1.08
[packages/perl-DBD-XBase.git] / perl-DBD-XBase.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    DBD
6 %define         pnam    XBase
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        XBase - reading and writing the DBF files from Perl
9 Summary(pl.UTF-8):      XBase - czytanie i zapisywanie plików DBF z poziomu Perla
10 Name:           perl-DBD-XBase
11 Version:        1.08
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  46c96ad148c7b52025e7699e68771caa
18 URL:            http://search.cpan.org/dist/DBD-XBase/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  perl-DBI
23 %endif
24 BuildArch:      noarch
25 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
26
27 %description
28 This module can read and write XBase database files, known as dbf in
29 dBase and FoxPro world. It also reads memo fields from the dbt and fpt
30 files, if needed. An alpha code of reading index support for ndx, ntx,
31 mdx, idx and cdx is available for testing - see the DBD::Index(3) man
32 page. Module XBase provides simple native interface to XBase files.
33 For DBI compliant database access, see the DBD::XBase and DBI modules
34 and their man pages.
35
36 %description -l pl.UTF-8
37 Ten moduł może czytać i zapisywać pliki baz danych XBase, znane jako
38 dbf w świecie dBase i FoxPro. Może także czytać w razie potrzeby pola
39 memo w plików dbt i fpt. Kod w fazie alpha czytający indeksy ndx, ntx,
40 mdx, idx i cdx jest dostępny do testowania - więcej w DBD::Index(3).
41 Moduł XBase udostępnia prosty natywny interfejs do plików XBase.
42 Więcej o zgodnym z DBI dostępie do baz danych można dowiedzieć się z
43 modułów i stron manuala DBD::XBase i DBI.
44
45 %prep
46 %setup -q -n %{pdir}-%{pnam}-%{version}
47
48 %build
49 %{__perl} Makefile.PL \
50         INSTALLDIRS=vendor
51 %{__make}
52
53 %{?with_tests:%{__make} test}
54
55 %install
56 rm -rf $RPM_BUILD_ROOT
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT
60
61 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
62 cp -a eg/* $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
63
64 # get rid of pod documentation
65 rm -f $RPM_BUILD_ROOT%{perl_vendorlib}/XBase/*.pod
66
67 %clean
68 rm -rf $RPM_BUILD_ROOT
69
70 %files
71 %defattr(644,root,root,755)
72 %doc Changes README ToDo
73 %attr(755,root,root) %{_bindir}/*dump
74 %{perl_vendorlib}/DBD/XBase.pm
75 %{perl_vendorlib}/XBase.pm
76 %{perl_vendorlib}/XBase
77 %{_mandir}/man[13]/*
78 %{_examplesdir}/%{name}-%{version}
This page took 0.055075 seconds and 3 git commands to generate.