]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blob - perl-DBD-SQLite.spec
- up to 0.30
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    SQLite
8 Summary:        DBD::SQLite - DBI driver for SQLite database
9 Summary(pl):    DBD::SQLite - sterownik DBI dla bazy SQLite
10 Name:           perl-DBD-SQLite
11 Version:        0.30
12 Release:        0.1
13 License:        GPL or Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  c5bccf84c698beb7b3063e4371151e88
17 BuildRequires:  perl-devel >= 5.8
18 %if %{with tests}
19 BuildRequires:  perl-DBI
20 %endif
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %description
25 DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
26 domain RDBMS database engine that you can find at
27 http://www.hwaci.com/sw/sqlite/.
28
29 %description -l pl
30 DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
31 relacyjnych baz danych na licencji public domain. Mo¿na go znale¼æ pod
32 http://www.hwaci.com/sw/sqlite/.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40
41 # If SQLITE_PTR_SZ is not set in OPTIMIZE SQLite assumes 64-bit
42 # architecture and fails. 
43 %{__make} \
44         OPTIMIZE="%{rpmcflags} -DSQLITE_PTR_SZ=`%{__perl} -MConfig -e 'print \"$Config{ptrsize}\";'`"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes README
60 %{perl_vendorarch}/DBD/SQLite.pm
61 %dir %{perl_vendorarch}/auto/DBD/SQLite
62 %{perl_vendorarch}/auto/DBD/SQLite/SQLite.bs
63 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
64 %{_mandir}/man3/DBD*
This page took 0.045913 seconds and 4 git commands to generate.