]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blob - perl-DBD-SQLite.spec
- up to 1.11
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    SQLite
8 Summary:        DBD::SQLite - Self Contained RDBMS in a DBI Driver (sqlite 3.x)
9 Summary(pl):    DBD::SQLite - Kompletny RDBMS zawarty w sterowniku DBI (sqlite 3.x)
10 Name:           perl-DBD-SQLite
11 Version:        1.11
12 Release:        1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  7f22d8789245047343e114e655571022
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-DBI
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
27 domain RDBMS database engine that you can find at
28 <http://www.sqlite.org/>.
29
30 Rather than ask you to install SQLite first, DBD::SQLite includes the
31 entire thing in the distribution. So in order to get a fast
32 transaction capable RDBMS working for your perl project you simply
33 have to install this module, and nothing else.
34
35 To use databases created using older SQLite version (2.x) you should
36 use perl-DBD-SQLite2 package.
37
38 %description -l pl
39 DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
40 relacyjnych baz danych na licencji public domain. Mo¿na go znale¼æ pod
41 adresem <http://www.sqlite.org/>.
42
43 DBD::SQLite zawiera w sobie ca³y silnik bazy danych. Dziêki temu aby
44 otrzymaæ dzia³aj±cy RDBMS dostêpny z poziomu Perla nie trzeba
45 instalowaæ ¿adnych innych pakietów.
46
47 Aby u¿ywaæ baz danych stworzonych przy pomocy starszej wersji SQLite
48 (2.x) nale¿y zainstalowaæ pakiet perl-DBD-SQLite2.
49
50 %prep
51 %setup -q -n %{pdir}-%{pnam}-%{version}
52
53 %build
54 echo y | %{__perl} Makefile.PL \
55         INSTALLDIRS=vendor
56
57 # If SQLITE_PTR_SZ is not set in OPTIMIZE SQLite assumes 64-bit
58 # architecture and fails. 
59 %{__make} \
60         OPTIMIZE="%{rpmcflags} -DSQLITE_PTR_SZ=`%{__perl} -MConfig -e 'print \"$Config{ptrsize}\";'`"
61
62 %{?with_tests:%{__make} test}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66
67 %{__make} install \
68         DESTDIR=$RPM_BUILD_ROOT
69
70 %clean
71 rm -rf $RPM_BUILD_ROOT
72
73 %files
74 %defattr(644,root,root,755)
75 %doc Changes README
76 %{perl_vendorarch}/DBD/SQLite.pm
77 %dir %{perl_vendorarch}/auto/DBD/SQLite
78 %{perl_vendorarch}/auto/DBD/SQLite/SQLite.bs
79 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
80 %{_mandir}/man3/DBD*
This page took 0.196861 seconds and 4 git commands to generate.