]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blob - perl-DBD-SQLite.spec
- rebuild for perl 5.20
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 %bcond_without  system_sqlite3  # don't use system sqlite3
5 #
6 %include        /usr/lib/rpm/macros.perl
7 %define         pdir    DBD
8 %define         pnam    SQLite
9 Summary:        DBD::SQLite - Self Contained RDBMS in a DBI Driver (sqlite 3.x)
10 Summary(pl.UTF-8):      DBD::SQLite - Kompletny RDBMS zawarty w sterowniku DBI (sqlite 3.x)
11 Name:           perl-DBD-SQLite
12 Version:        1.39
13 Release:        2
14 # same as perl
15 License:        GPL v1+ or Artistic
16 Group:          Development/Languages/Perl
17 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
18 # Source0-md5:  8ca0719852fcbcbbee470c705eeff24a
19 URL:            http://search.cpan.org/dist/DBD-SQLite/
20 BuildRequires:  perl-DBI >= 1.57
21 BuildRequires:  perl-devel >= 1:5.8.0
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 %{?with_system_sqlite3:BuildRequires:   sqlite3-devel >= 3.6.0}
24 %if %{with tests}
25 BuildRequires:  perl-Encode
26 BuildRequires:  perl-Test-Simple >= 0.86
27 %endif
28 %{?with_system_sqlite3:Requires:        sqlite3 >= 3.6.0}
29 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
30
31 %description
32 DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
33 domain RDBMS database engine that you can find at
34 <http://www.sqlite.org/>.
35
36 Rather than ask you to install SQLite first, DBD::SQLite includes the
37 entire thing in the distribution. So in order to get a fast
38 transaction capable RDBMS working for your perl project you simply
39 have to install this module, and nothing else.
40
41 To use databases created using older SQLite version (2.x) you should
42 use perl-DBD-SQLite2 package.
43
44 %description -l pl.UTF-8
45 DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
46 relacyjnych baz danych na licencji public domain. Można go znaleźć pod
47 adresem <http://www.sqlite.org/>.
48
49 DBD::SQLite zawiera w sobie cały silnik bazy danych. Dzięki temu aby
50 otrzymać działający RDBMS dostępny z poziomu Perla nie trzeba
51 instalować żadnych innych pakietów.
52
53 Aby używać baz danych stworzonych przy pomocy starszej wersji SQLite
54 (2.x) należy zainstalować pakiet perl-DBD-SQLite2.
55
56 %prep
57 %setup -q -n %{pdir}-%{pnam}-%{version}
58
59 # honour USE_LOCAL_SQLITE instead of using bundled sqlite3 (see comments inside)
60 %{__perl} -pi -e 's/if \( 0 \)/if ( 1 )/' Makefile.PL
61
62 %build
63 echo y | %{__perl} Makefile.PL \
64         %{!?with_system_sqlite3:USE_LOCAL_SQLITE=1} \
65         INSTALLDIRS=vendor
66
67 %{__make} \
68         CC="%{__cc}" \
69         OPTIMIZE="%{rpmcflags}" \
70         OTHERLDFLAGS="%{rpmcflags} %{rpmldflags}"
71
72 %{?with_tests:%{__make} test}
73
74 %install
75 rm -rf $RPM_BUILD_ROOT
76
77 %{__make} install \
78         DESTDIR=$RPM_BUILD_ROOT
79
80 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/SQLite/Cookbook.pod
81 # "sqlite3 amalgamation" sources
82 %{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/auto/share
83
84 %clean
85 rm -rf $RPM_BUILD_ROOT
86
87 %files
88 %defattr(644,root,root,755)
89 %doc Changes README
90 %{perl_vendorarch}/DBD/SQLite.pm
91 %dir %{perl_vendorarch}/auto/DBD/SQLite
92 %{perl_vendorarch}/auto/DBD/SQLite/SQLite.bs
93 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
94 %{_mandir}/man3/DBD::SQLite.3pm*
95 %{_mandir}/man3/DBD::SQLite::Cookbook.3pm*
This page took 0.062634 seconds and 4 git commands to generate.