]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blob - perl-DBD-SQLite.spec
- fixed perl-devel BR
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    SQLite
8 Summary:        DBD::SQLite - DBI driver for SQLite database
9 Summary(pl):    DBD::SQLite - sterownik DBI dla bazy SQLite
10 Name:           perl-DBD-SQLite
11 Version:        0.31
12 Release:        0.1
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  4aa99c39104b7cd39129aec548e7d3e4
18 BuildRequires:  perl-devel >= 1:5.8.0
19 %if %{with tests}
20 BuildRequires:  perl-DBI
21 %endif
22 BuildRequires:  rpm-perlprov >= 4.1-13
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
27 domain RDBMS database engine that you can find at
28 http://www.hwaci.com/sw/sqlite/.
29
30 %description -l pl
31 DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
32 relacyjnych baz danych na licencji public domain. Mo¿na go znale¼æ pod
33 http://www.hwaci.com/sw/sqlite/.
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37
38 %build
39 %{__perl} Makefile.PL \
40         INSTALLDIRS=vendor
41
42 # If SQLITE_PTR_SZ is not set in OPTIMIZE SQLite assumes 64-bit
43 # architecture and fails. 
44 %{__make} \
45         OPTIMIZE="%{rpmcflags} -DSQLITE_PTR_SZ=`%{__perl} -MConfig -e 'print \"$Config{ptrsize}\";'`"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/DBD/SQLite.pm
62 %dir %{perl_vendorarch}/auto/DBD/SQLite
63 %{perl_vendorarch}/auto/DBD/SQLite/SQLite.bs
64 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
65 %{_mandir}/man3/DBD*
This page took 0.069915 seconds and 4 git commands to generate.