]> git.pld-linux.org Git - packages/perl-DBD-SQLite.git/blob - perl-DBD-SQLite.spec
rebuild with perl 5.32
[packages/perl-DBD-SQLite.git] / perl-DBD-SQLite.spec
1 #
2 # Conditional build:
3 %bcond_without  tests           # do not perform "make test"
4 %bcond_without  system_sqlite3  # don't use system sqlite3
5 #
6 %define         pdir    DBD
7 %define         pnam    SQLite
8 Summary:        DBD::SQLite - Self Contained RDBMS in a DBI Driver (sqlite 3.x)
9 Summary(pl.UTF-8):      DBD::SQLite - Kompletny RDBMS zawarty w sterowniku DBI (sqlite 3.x)
10 Name:           perl-DBD-SQLite
11 Version:        1.64
12 Release:        3
13 # same as perl
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  10796495b52927eb2e1df34c86924027
18 URL:            https://metacpan.org/release/DBD-SQLite
19 BuildRequires:  perl-DBI >= 1.57
20 BuildRequires:  perl-devel >= 1:5.8.0
21 BuildRequires:  rpm-perlprov >= 4.1-13
22 BuildRequires:  rpmbuild(macros) >= 1.745
23 %{?with_system_sqlite3:BuildRequires:   sqlite3-devel >= 3.6.0}
24 %if %{with tests}
25 BuildRequires:  perl-Encode
26 BuildRequires:  perl-Test-Simple >= 0.86
27 # needs ENABLE_FTS3_PARENTHESIS
28 %{?with_system_sqlite3:BuildRequires:   sqlite3 >= 3.8.11.1-2}
29 %endif
30 %{?with_system_sqlite3:Requires:        sqlite3 >= 3.6.0}
31 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33 # virtual module provided by VirtualTable.pm
34 %define         _noautoreq_perl DBD::SQLite::VirtualTable::Cursor
35
36 %description
37 DBD::SQLite is a DBI driver for SQLite database. SQLite is a public
38 domain RDBMS database engine that you can find at
39 <http://www.sqlite.org/>.
40
41 Rather than ask you to install SQLite first, DBD::SQLite includes the
42 entire thing in the distribution. So in order to get a fast
43 transaction capable RDBMS working for your perl project you simply
44 have to install this module, and nothing else.
45
46 To use databases created using older SQLite version (2.x) you should
47 use perl-DBD-SQLite2 package.
48
49 %description -l pl.UTF-8
50 DBD::SQLite to sterownik DBI do baz danych SQLite. SQLite to silnik
51 relacyjnych baz danych na licencji public domain. Można go znaleźć pod
52 adresem <http://www.sqlite.org/>.
53
54 DBD::SQLite zawiera w sobie cały silnik bazy danych. Dzięki temu aby
55 otrzymać działający RDBMS dostępny z poziomu Perla nie trzeba
56 instalować żadnych innych pakietów.
57
58 Aby używać baz danych stworzonych przy pomocy starszej wersji SQLite
59 (2.x) należy zainstalować pakiet perl-DBD-SQLite2.
60
61 %prep
62 %setup -q -n %{pdir}-%{pnam}-%{version}
63
64 # honour USE_LOCAL_SQLITE instead of using bundled sqlite3 (see comments inside)
65 %{__perl} -pi -e 's/if \( 0 \)/if ( 1 )/' Makefile.PL
66
67 %build
68 echo y | %{__perl} Makefile.PL \
69         %{!?with_system_sqlite3:USE_LOCAL_SQLITE=1} \
70         INSTALLDIRS=vendor
71
72 %{__make} \
73         CC="%{__cc}" \
74         OPTIMIZE="%{rpmcflags}" \
75         OTHERLDFLAGS="%{rpmcflags} %{rpmldflags}"
76
77 %{?with_tests:%{__make} test}
78
79 %install
80 rm -rf $RPM_BUILD_ROOT
81
82 %{__make} install \
83         DESTDIR=$RPM_BUILD_ROOT
84
85 %{__rm} $RPM_BUILD_ROOT%{perl_vendorarch}/DBD/SQLite/{Cookbook,Fulltext_search}.pod
86 # "sqlite3 amalgamation" sources
87 %{__rm} -r $RPM_BUILD_ROOT%{perl_vendorarch}/auto/share
88
89 %clean
90 rm -rf $RPM_BUILD_ROOT
91
92 %files
93 %defattr(644,root,root,755)
94 %doc Changes README
95 %{perl_vendorarch}/DBD/SQLite.pm
96 %{perl_vendorarch}/DBD/SQLite
97 %dir %{perl_vendorarch}/auto/DBD/SQLite
98 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/SQLite/SQLite.so
99 %{_mandir}/man3/DBD::SQLite*.3pm*
This page took 0.065654 seconds and 3 git commands to generate.