]> git.pld-linux.org Git - packages/perl-DBD-ODBC.git/blob - perl-DBD-ODBC.spec
- rebuild with perl 5.30.0
[packages/perl-DBD-ODBC.git] / perl-DBD-ODBC.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    DBD
7 %define         pnam    ODBC
8 Summary:        DBD::ODBC - ODBC Driver for DBI
9 Summary(pl.UTF-8):      DBD::ODBC - sterownik DBI do ODBC
10 Name:           perl-DBD-ODBC
11 Version:        1.60
12 Release:        3
13 # GPL or Artistic as specified in perl README file
14 License:        GPL v1+ or Artistic
15 Group:          Development/Languages/Perl
16 Source0:        http://www.cpan.org/modules/by-module/DBD/%{pdir}-%{pnam}-%{version}.tar.gz
17 # Source0-md5:  e9a2bec96744f960832e4f47f9e4bcd0
18 URL:            http://search.cpan.org/dist/DBD-ODBC/
19 BuildRequires:  perl-DBI >= 1.21
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRequires:  unixODBC-devel
22 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
24 %define         __noautoreqfiles        Changes.pm FAQ.pm TO_DO.pm
25
26 %description
27 DBD::ODBC is DBD module interfacing the ODBC databases.
28
29 %description -l pl.UTF-8
30 DBD::ODBC jest modułem DBD komunikującym się z bazami danych z użyciem
31 ODBC.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 # pass PERL_MM_USE_DEFAULT to avoid threads warning prompt
38 PERL_MM_USE_DEFAULT=1 \
39 %{__perl} Makefile.PL \
40         -o /usr \
41         INSTALLDIRS=vendor
42
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %install
48 rm -rf $RPM_BUILD_ROOT
49
50 %{__make} install \
51         DESTDIR=$RPM_BUILD_ROOT
52
53 %{?with_tests:%{__make} test}
54
55 %clean
56 rm -rf $RPM_BUILD_ROOT
57
58 %files
59 %defattr(644,root,root,755)
60 %doc Changes README
61 %{perl_vendorarch}/DBD/ODBC.pm
62 %{perl_vendorarch}/DBD/ODBC
63 %dir %{perl_vendorarch}/auto/DBD/ODBC
64 %attr(755,root,root) %{perl_vendorarch}/auto/DBD/ODBC/ODBC.so
65 %{_mandir}/man3/DBD::ODBC.3pm*
This page took 0.063758 seconds and 3 git commands to generate.