]> git.pld-linux.org Git - packages/perl-Crypt-Twofish2.git/blob - perl-Crypt-Twofish2.spec
- up to 1.01
[packages/perl-Crypt-Twofish2.git] / perl-Crypt-Twofish2.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Twofish2
8 Summary:        Crypt::Twofish2 - Crypt::CBC compliant Twofish encryption Perl module
9 Summary(pl):    Crypt::Twofish2 - perlowy modu³ szyfru Twofish zgodny z Crypt::CBC
10 Name:           perl-Crypt-Twofish2
11 Version:        1.01
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  e7c6e90ddf22306ebcc1a91df47c26d9
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 This module implements the Twofish cipher in a less braindamaged
23 (read: slow and ugly) way than the existing "Crypt::Twofish" module.
24 Although it is "Crypt::CBC" compliant you usually gain nothing by
25 using that module (except generality), since "Crypt::Twofish2" can
26 work in either ECB or CBC mode.
27
28 %description -l pl
29 Ten modu³ jest implementacj± szyfru Twofish w mniej debilny (powolny
30 i paskudny) sposób ni¿ modu³ Crypt::Twofish. Pomimo tego, ¿e jest
31 zgodny z Crypt::CBC, nie ma potrzeby u¿ywania tamtego modu³u, poniewa¿
32 Crypt::Twofish2 mo¿e dzia³aæ zarówno w trybie ECB jak i CBC.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         OPTIMIZE="%{rpmcflags}"
42
43 %{?with_tests:%{__make} test}
44
45 %install
46 rm -rf $RPM_BUILD_ROOT
47
48 %{__make} install \
49         DESTDIR=$RPM_BUILD_ROOT
50
51 %clean
52 rm -rf $RPM_BUILD_ROOT
53
54 %files
55 %defattr(644,root,root,755)
56 %doc Changes README
57 %{perl_vendorarch}/Crypt/Twofish2.pm
58 %dir %{perl_vendorarch}/auto/Crypt/Twofish2
59 %{perl_vendorarch}/auto/Crypt/Twofish2/*.bs
60 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish2/*.so
61 %{_mandir}/man3/*
This page took 0.05936 seconds and 4 git commands to generate.