]> git.pld-linux.org Git - packages/perl-Crypt-Twofish2.git/blob - perl-Crypt-Twofish2.spec
- new
[packages/perl-Crypt-Twofish2.git] / perl-Crypt-Twofish2.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define         pdir    Crypt
6 %define         pnam    Twofish2
7 Summary:        Crypt::Twofish2 - Crypt::CBC compliant Twofish encryption Perl module
8 Summary(pl):    Crypt::Twofish2 - perlowy modu³ szyfru Twofish zgodny z Crypt::CBC
9 Name:           perl-Crypt-Twofish2
10 Version:        0.06
11 Release:        1
12 License:        GPL
13 Group:          Development/Languages/Perl
14 Source0:        ftp://ftp.cpan.org/pub/CPAN/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 BuildRequires:  perl-devel >= 5.6
16 BuildRequires:  rpm-perlprov >= 3.0.3-16
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 This module implements the Twofish cipher in a less braindamaged
21 (read: slow and ugly) way than the existing "Crypt::Twofish" module.
22 Although it is "Crypt::CBC" compliant you usually gain nothing by
23 using that module (except generality), since "Crypt::Twofish2" can
24 work in either ECB or CBC mode.
25
26 %description -l pl
27 Ten modu³ jest implementacj± szyfru Twofish w mniej debilny (powolny
28 i paskudny) sposób ni¿ modu³ Crypt::Twofish. Pomimo tego, ¿e jest
29 zgodny z Crypt::CBC, nie ma potrzeby u¿ywania tamtego modu³u, poniewa¿
30 Crypt::Twofish2 mo¿e dzia³aæ zarówno w trybie ECB jak i CBC.
31
32 %prep
33 %setup -q -n %{pdir}-%{pnam}-%{version}
34
35 %build
36 perl Makefile.PL
37 %{__make} OPTIMIZE="%{rpmcflags}"
38 %{!?_without_tests:%{__make} test}
39
40 %install
41 rm -rf $RPM_BUILD_ROOT
42
43 %{__make} install \
44         DESTDIR=$RPM_BUILD_ROOT
45
46 %clean
47 rm -rf $RPM_BUILD_ROOT
48
49 %files
50 %defattr(644,root,root,755)
51 %doc Changes README
52 %{perl_sitearch}/Crypt/Twofish2.pm
53 %dir %{perl_sitearch}/auto/Crypt/Twofish2
54 %{perl_sitearch}/auto/Crypt/Twofish2/*.bs
55 %attr(755,root,root) %{perl_sitearch}/auto/Crypt/Twofish2/*.so
56 %{_mandir}/man3/*
This page took 0.079087 seconds and 4 git commands to generate.