]> git.pld-linux.org Git - packages/perl-Crypt-Twofish2.git/blob - perl-Crypt-Twofish2.spec
- license fixes and unification
[packages/perl-Crypt-Twofish2.git] / perl-Crypt-Twofish2.spec
1 #
2 # Conditional build:
3 # _without_tests - do not perform "make test"
4 %include        /usr/lib/rpm/macros.perl
5 %define         pdir    Crypt
6 %define         pnam    Twofish2
7 Summary:        Crypt::Twofish2 - Crypt::CBC compliant Twofish encryption Perl module
8 Summary(pl):    Crypt::Twofish2 - perlowy modu³ szyfru Twofish zgodny z Crypt::CBC
9 Name:           perl-Crypt-Twofish2
10 Version:        0.06
11 Release:        2
12 License:        Artistic
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  1d8811f218015a8a0200d08157f78b14
16 BuildRequires:  perl-devel >= 5.6
17 BuildRequires:  rpm-perlprov >= 4.1-13
18 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
19
20 %description
21 This module implements the Twofish cipher in a less braindamaged
22 (read: slow and ugly) way than the existing "Crypt::Twofish" module.
23 Although it is "Crypt::CBC" compliant you usually gain nothing by
24 using that module (except generality), since "Crypt::Twofish2" can
25 work in either ECB or CBC mode.
26
27 %description -l pl
28 Ten modu³ jest implementacj± szyfru Twofish w mniej debilny (powolny
29 i paskudny) sposób ni¿ modu³ Crypt::Twofish. Pomimo tego, ¿e jest
30 zgodny z Crypt::CBC, nie ma potrzeby u¿ywania tamtego modu³u, poniewa¿
31 Crypt::Twofish2 mo¿e dzia³aæ zarówno w trybie ECB jak i CBC.
32
33 %prep
34 %setup -q -n %{pdir}-%{pnam}-%{version}
35
36 %build
37 %{__perl} Makefile.PL \
38         INSTALLDIRS=vendor
39 %{__make} OPTIMIZE="%{rpmcflags}"
40 %{!?_without_tests:%{__make} test}
41
42 %install
43 rm -rf $RPM_BUILD_ROOT
44
45 %{__make} install \
46         DESTDIR=$RPM_BUILD_ROOT
47
48 %clean
49 rm -rf $RPM_BUILD_ROOT
50
51 %files
52 %defattr(644,root,root,755)
53 %doc Changes README
54 %{perl_vendorarch}/Crypt/Twofish2.pm
55 %dir %{perl_vendorarch}/auto/Crypt/Twofish2
56 %{perl_vendorarch}/auto/Crypt/Twofish2/*.bs
57 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish2/*.so
58 %{_mandir}/man3/*
This page took 0.099966 seconds and 4 git commands to generate.