]> git.pld-linux.org Git - packages/perl-Crypt-Twofish.git/blob - perl-Crypt-Twofish.spec
- updated to 2.17
[packages/perl-Crypt-Twofish.git] / perl-Crypt-Twofish.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Twofish
8 Summary:        Crypt::Twofish Perl module - the Twofish encryption algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Twofish - algorytm szyfrowania Twofish
10 Name:           perl-Crypt-Twofish
11 Version:        2.17
12 Release:        1
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  bb6e7ec9ff6db6aea27dce7175a852e2
17 Patch0:         no-dot-in-inc.patch
18 URL:            http://search.cpan.org/dist/Crypt-Twofish/
19 BuildRequires:  perl-devel >= 1:5.8.0
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 This module implements Twofish encryption. It supports the Crypt::CBC
25 interface. Twofish is a 128-bit symmetric block cipher with a variable
26 length (128, 192, or 256-bit) key, developed by Counterpane Labs. It
27 is unpatented and free for all uses, as described at
28 <http://www.counterpane.com/twofish.html>.
29
30 %description -l pl.UTF-8
31 Ten moduł jest implementacją szyfrowania Twofish. Obsługuje interfejs
32 Crypt::CBC. Twofish jest 128-bitowym symetrycznym szyfrem blokowym ze
33 zmienną długością klucza (128, 192 lub 256 bitów), opracowanym przez
34 Counterpane Labs. Nie jest opatentowany i można go swobodnie używać
35 do dowolnych celów, zgodnie z opisem pod adresem
36 <http://www.counterpane.com/twofish.html>.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40 %patch0 -p1
41
42 %build
43 %{__perl} Makefile.PL \
44         INSTALLDIRS=vendor
45 %{__make} \
46         CC="%{__cc}" \
47         OPTIMIZE="%{rpmcflags}"
48
49 %{?with_tests:%{__make} test}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53
54 %{__make} install \
55         DESTDIR=$RPM_BUILD_ROOT
56
57 %clean
58 rm -rf $RPM_BUILD_ROOT
59
60 %files
61 %defattr(644,root,root,755)
62 %doc Changes README
63 %{perl_vendorarch}/Crypt/Twofish.pm
64 %dir %{perl_vendorarch}/auto/Crypt/Twofish
65 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Twofish/*.so
66 %{_mandir}/man3/*
This page took 0.084135 seconds and 3 git commands to generate.