]> git.pld-linux.org Git - packages/perl-Crypt-TEA.git/blob - perl-Crypt-TEA.spec
- release 10 (by relup.sh)
[packages/perl-Crypt-TEA.git] / perl-Crypt-TEA.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    TEA
8 Summary:        Crypt::TEA Perl module - Tiny Encryption Algorithm
9 Summary(pl.UTF-8):      Moduł Perla Crypt::TEA - Tiny Encryption Algorithm
10 Name:           perl-Crypt-TEA
11 Version:        1.25
12 Release:        10
13 License:        Artistic
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  6e53511e455724b40007e4f2c0050270
17 URL:            http://search.cpan.org/dist/Crypt-TEA/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 This module implements TEA (Tiny Encryption Algorithm) encryption. It
24 supports the Crypt::CBC interface. TEA is a 64-bit symmetric block
25 cipher with a 128-bit key and a variable number of rounds (32 is
26 recommended). It has a low setup time, and depends on a large number
27 of rounds for security, rather than a complex algorithm. It was
28 developed by David J. Wheeler and Roger M. Needham, and is described
29 at <http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html>.
30
31 %description -l pl.UTF-8
32 Ten moduł jest implementacją szyfrowania TEA (Tiny Encryption
33 Algorithm - niewielki algorytm szyfrowania). Obsługuje interfejs
34 Crypt::CBC. TEA jest 64-bitowym symetrycznym szyfrem blokowym ze
35 128-bitowym kluczem i zmienną liczbą kroków (zaleca się 32). Wymaga
36 mało czasu do uruchomienia i dla zapewnienia bezpieczeństwa polega na
37 dużej liczbie kroków, a nie skomplikowanym algorytmie. TEA został
38 opracowany przez Davida J. Wheelera i Rogera M. Needhama, a jego opis
39 można znaleźć pod adresem:
40 <http://www.ftp.cl.cam.ac.uk/ftp/papers/djw-rmn/djw-rmn-tea.html>.
41
42 %prep
43 %setup -q -n %{pdir}-%{pnam}-%{version}
44
45 %build
46 %{__perl} Makefile.PL \
47         INSTALLDIRS=vendor
48 %{__make} \
49         CC="%{__cc}" \
50         OPTIMIZE="%{rpmcflags}"
51
52 %{?with_tests:%{__make} test}
53
54 %install
55 rm -rf $RPM_BUILD_ROOT
56
57 %{__make} install \
58         DESTDIR=$RPM_BUILD_ROOT
59
60 %clean
61 rm -rf $RPM_BUILD_ROOT
62
63 %files
64 %defattr(644,root,root,755)
65 %doc Changes README
66 %{perl_vendorarch}/Crypt/TEA.pm
67 %dir %{perl_vendorarch}/auto/Crypt/TEA
68 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/TEA/*.so
69 %{_mandir}/man3/*
This page took 0.057293 seconds and 3 git commands to generate.