]> git.pld-linux.org Git - packages/perl-Crypt-Skipjack.git/blob - perl-Crypt-Skipjack.spec
8d2b4031dca75f7023496bcefa953c8a796614a9
[packages/perl-Crypt-Skipjack.git] / perl-Crypt-Skipjack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %include        /usr/lib/rpm/macros.perl
6 %define         pdir    Crypt
7 %define         pnam    Skipjack
8 Summary:        Crypt::Skipjack - Crypt::CBC-compliant block cipher
9 Summary(pl.UTF-8):      Crypt::Skipjack - szyfr blokowy kompatybilny z Crypt::CBC
10 Name:           perl-Crypt-Skipjack
11 Version:        1.0.2
12 Release:        8
13 License:        GPL v2
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  46196172e7020917f8249f36f8b55c21
17 URL:            http://search.cpan.org/dist/Crypt-Skipjack/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Skipjack is the secret key encryption algorithm designed by the
24 National Security Agency, and is used in the Clipper chip and Fortezza
25 PC card. It was implemented in tamper-resistant hardware and its
26 structure had been classified since its introduction in 1993. Skipjack
27 was unclassified on June 24, 1998. Skipjack is an 80-bit key, 64-bit
28 block cipher. This module supports the Crypt::CBC interface.
29
30 %description -l pl.UTF-8
31 Skipjack to algorytm szyfrowania klucza tajnego opracowany przez NSA
32 (National Security Agency), używany w układzie Clipper i kartach PC
33 Fortezza. Był zaimplementowany w zabezpieczonym przed intruzami
34 sprzęcie, a jego struktura była zastrzeżona od wprowadzenia w 1993
35 roku do 24 czerwca 1998. Skipjack to 64-bitowy szyfr blokowy z
36 80-bitowym kluczem. Ten moduł obsługuje interfejs Crypt::CBC.
37
38 %prep
39 %setup -q -n %{pdir}-%{pnam}-%{version}
40
41 %build
42 %{__perl} Makefile.PL \
43         INSTALLDIRS=vendor
44 %{__make} \
45         CC="%{__cc}" \
46         OPTIMIZE="%{rpmcflags}"
47
48 %{?with_tests:%{__make} test}
49
50 %install
51 rm -rf $RPM_BUILD_ROOT
52
53 %{__make} install \
54         DESTDIR=$RPM_BUILD_ROOT
55 cd examples
56 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
57 for f in * ; do
58         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
59                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
60 done
61
62 %clean
63 rm -rf $RPM_BUILD_ROOT
64
65 %files
66 %defattr(644,root,root,755)
67 %doc Changes README
68 %{perl_vendorarch}/Crypt/Skipjack.pm
69 %dir %{perl_vendorarch}/auto/Crypt/Skipjack
70 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Skipjack/Skipjack.so
71 %{_mandir}/man3/*
72 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.13891 seconds and 2 git commands to generate.