]> git.pld-linux.org Git - packages/perl-Crypt-Skipjack.git/blob - perl-Crypt-Skipjack.spec
3e8d8d9c3a987e79fe87adff98e243eb1e57d10e
[packages/perl-Crypt-Skipjack.git] / perl-Crypt-Skipjack.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # Do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Skipjack
7 Summary:        Crypt::Skipjack - Crypt::CBC-compliant block cipher
8 Summary(pl.UTF-8):      Crypt::Skipjack - szyfr blokowy kompatybilny z Crypt::CBC
9 Name:           perl-Crypt-Skipjack
10 Version:        1.0.2
11 Release:        15
12 License:        GPL v2
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  46196172e7020917f8249f36f8b55c21
16 URL:            http://search.cpan.org/dist/Crypt-Skipjack/
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Skipjack is the secret key encryption algorithm designed by the
23 National Security Agency, and is used in the Clipper chip and Fortezza
24 PC card. It was implemented in tamper-resistant hardware and its
25 structure had been classified since its introduction in 1993. Skipjack
26 was unclassified on June 24, 1998. Skipjack is an 80-bit key, 64-bit
27 block cipher. This module supports the Crypt::CBC interface.
28
29 %description -l pl.UTF-8
30 Skipjack to algorytm szyfrowania klucza tajnego opracowany przez NSA
31 (National Security Agency), używany w układzie Clipper i kartach PC
32 Fortezza. Był zaimplementowany w zabezpieczonym przed intruzami
33 sprzęcie, a jego struktura była zastrzeżona od wprowadzenia w 1993
34 roku do 24 czerwca 1998. Skipjack to 64-bitowy szyfr blokowy z
35 80-bitowym kluczem. Ten moduł obsługuje interfejs Crypt::CBC.
36
37 %prep
38 %setup -q -n %{pdir}-%{pnam}-%{version}
39
40 %build
41 %{__perl} Makefile.PL \
42         INSTALLDIRS=vendor
43 %{__make} \
44         CC="%{__cc}" \
45         OPTIMIZE="%{rpmcflags}"
46
47 %{?with_tests:%{__make} test}
48
49 %install
50 rm -rf $RPM_BUILD_ROOT
51
52 %{__make} install \
53         DESTDIR=$RPM_BUILD_ROOT
54 cd examples
55 install -d $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}
56 for f in * ; do
57         sed -e "s@#!/usr/local/bin/perl@#!/usr/bin/perl@" $f \
58                 > $RPM_BUILD_ROOT%{_examplesdir}/%{name}-%{version}/$f
59 done
60
61 %clean
62 rm -rf $RPM_BUILD_ROOT
63
64 %files
65 %defattr(644,root,root,755)
66 %doc Changes README
67 %{perl_vendorarch}/Crypt/Skipjack.pm
68 %dir %{perl_vendorarch}/auto/Crypt/Skipjack
69 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Skipjack/Skipjack.so
70 %{_mandir}/man3/*
71 %attr(755,root,root) %{_examplesdir}/%{name}-%{version}
This page took 0.090976 seconds and 2 git commands to generate.