]> git.pld-linux.org Git - packages/perl-Crypt-SMIME.git/blob - perl-Crypt-SMIME.spec
c4fee9d4c6cc099a7b96d42290866cfa3f7c68ff
[packages/perl-Crypt-SMIME.git] / perl-Crypt-SMIME.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    SMIME
7 Summary:        Crypt::SMIME - S/MIME message signing, verification, encryption and decryption
8 Summary(pl.UTF-8):      Crypt::SMIME - podpisywanie, weryfikacja, szyfrowanie i odszyfrowywanie wiadomości S/MIME
9 Name:           perl-Crypt-SMIME
10 Version:        0.25
11 Release:        1
12 License:        LGPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  7afe3f4dedd6f569efb1effcd432eacc
16 URL:            http://search.cpan.org/dist/Crypt-SMIME/
17 BuildRequires:  openssl-devel >= 0.9.9
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  perl(ExtUtils::CChecker)
20 BuildRequires:  rpm-perlprov >= 4.1-13
21 %if %{with tests}
22 BuildRequires:  openssl
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module provides a class for handling S/MIME messages. It can
28 sign, verify, encrypt and decrypt messages. It requires libcrypto
29 (http://www.openssl.org).
30
31 %description -l pl.UTF-8
32 Ten moduł dostarcza klasę do obsługi wiadomości S/MIME. Potrafi
33 podpisywać, weryfikować podpisy, szyfrować i odszyfrowywać takie
34 wiadomości. Wymaga biblioteki libcrypto z pakietu OpenSSL.
35
36 %prep
37 %setup -q -n %{pdir}-%{pnam}-%{version}
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %{__mv} $RPM_BUILD_ROOT%{_mandir}/man3/SMIME.3pm $RPM_BUILD_ROOT%{_mandir}/man3/Crypt::SMIME.3pm
55
56 %clean
57 rm -rf $RPM_BUILD_ROOT
58
59 %files
60 %defattr(644,root,root,755)
61 %doc Changes README
62 %{perl_vendorarch}/Crypt/SMIME.pm
63 %dir %{perl_vendorarch}/auto/Crypt/SMIME
64 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/SMIME/SMIME.so
65 %{_mandir}/man3/Crypt::SMIME.3*
This page took 0.076537 seconds and 2 git commands to generate.