]> git.pld-linux.org Git - packages/perl-Crypt-Rot13.git/blob - perl-Crypt-Rot13.spec
use generic url
[packages/perl-Crypt-Rot13.git] / perl-Crypt-Rot13.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4
5 %define         pdir    Crypt
6 %define         pnam    Rot13
7 %include        /usr/lib/rpm/macros.perl
8 Summary:        Crypt::Rot13 Perl module - a rotational deviator
9 Summary(pl.UTF-8):      Moduł Perla Crypt::Rot13 - obrotowy dewiator
10 Name:           perl-Crypt-Rot13
11 Version:        0.6
12 Release:        2
13 License:        GPL v2+
14 Group:          Development/Languages/Perl
15 Source0:        http://www.cpan.org/modules/by-module/%{pdir}/AYRNIEU/%{pdir}-%{pnam}-%{version}.tar.gz
16 # Source0-md5:  0898cc852619875a743678083152155a
17 URL:            http://search.cpan.org/dist/Crypt-Rot13/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 BuildArch:      noarch
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 Rot13 provides an object into which arrays may be placed, and then
25 returned to you in altered - specifically: rotated - form. Valid
26 rot13() arguments are 0-26, though 0 and 26 do not alter the array.
27
28 %description -l pl.UTF-8
29 Rot13 udostępnia obiekt, w którym można umieszczać tablice, które
30 następnie są zwracane w zmodyfikowanej, a konkretnie "obróconej"
31 formie. Prawidłowy argument dla rot13() to liczba z przedziału 0-26,
32 ale 0 i 26 nie zmieniają zawartości tablicy.
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make}
41 %{?with_tests: %{__make} test}
42
43 %install
44 rm -rf $RPM_BUILD_ROOT
45
46 %{__make} install \
47         DESTDIR=$RPM_BUILD_ROOT
48
49 %clean
50 rm -rf $RPM_BUILD_ROOT
51
52 %files
53 %defattr(644,root,root,755)
54 %doc Changes README
55 %{perl_vendorlib}/Crypt/Rot13.pm
56 %{_mandir}/man3/*
This page took 0.048672 seconds and 3 git commands to generate.