]> git.pld-linux.org Git - packages/perl-Crypt-Rijndael.git/blob - perl-Crypt-Rijndael.spec
rebuild with perl 5.32
[packages/perl-Crypt-Rijndael.git] / perl-Crypt-Rijndael.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Rijndael
7 Summary:        Crypt::Rijndael Perl module - Rijndael encryption algorithm
8 Summary(pl.UTF-8):      Moduł Perla Crypt::Rijndael - algorytm szyfrowania Rijndael
9 Name:           perl-Crypt-Rijndael
10 Version:        1.13
11 Release:        3
12 License:        LGPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  2af117c9ab4052cec05cf6737c5f3f45
16 Patch0:         %{name}-types.patch
17 URL:            http://search.cpan.org/dist/Crypt-Rijndael/
18 BuildRequires:  perl-devel >= 1:5.8.0
19 BuildRequires:  rpm-perlprov >= 4.1-13
20 %if %{with tests}
21 BuildRequires:  perl-Test-Manifest >= 1.21
22 BuildRequires:  perl-Test-Simple
23 %endif
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 This module is Crypt::CBC compliant Rijndael cipher implementation.
28 Rijndael has just been selected as the Advanced Encryption Standard.
29
30 %description -l pl.UTF-8
31 Ten moduł jest zgodną z Crypt::CBC implementacją szyfru Rijndael.
32 Rijndael został niedawno wybrany jako standard zaawansowanego
33 szyfrowania (AES).
34
35 %prep
36 %setup -q -n %{pdir}-%{pnam}-%{version}
37 %patch0 -p1
38
39 %build
40 %{__perl} Makefile.PL \
41         INSTALLDIRS=vendor
42 %{__make} \
43         CC="%{__cc}" \
44         OPTIMIZE="%{rpmcflags}"
45
46 %{?with_tests:%{__make} test}
47
48 %install
49 rm -rf $RPM_BUILD_ROOT
50
51 %{__make} install \
52         DESTDIR=$RPM_BUILD_ROOT
53
54 %clean
55 rm -rf $RPM_BUILD_ROOT
56
57 %files
58 %defattr(644,root,root,755)
59 %doc Changes NEWS README
60 %{perl_vendorarch}/Crypt/Rijndael.pm
61 %dir %{perl_vendorarch}/auto/Crypt/Rijndael
62 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Rijndael/Rijndael.so
63 %{_mandir}/man3/Crypt::Rijndael.3*
This page took 0.083609 seconds and 3 git commands to generate.