]> git.pld-linux.org Git - packages/perl-Crypt-Rijndael.git/blob - perl-Crypt-Rijndael.spec
8efa40facc6d31385c7063ed2bec2bdd57b26800
[packages/perl-Crypt-Rijndael.git] / perl-Crypt-Rijndael.spec
1 #
2 # Conditional build:
3 %bcond_without  tests   # do not perform "make test"
4 #
5 %define         pdir    Crypt
6 %define         pnam    Rijndael
7 Summary:        Crypt::Rijndael Perl module - Rijndael encryption algorithm
8 Summary(pl.UTF-8):      Moduł Perla Crypt::Rijndael - algorytm szyfrowania Rijndael
9 Name:           perl-Crypt-Rijndael
10 Version:        1.15
11 Release:        2
12 License:        LGPL v2+
13 Group:          Development/Languages/Perl
14 Source0:        http://www.cpan.org/modules/by-module/Crypt/%{pdir}-%{pnam}-%{version}.tar.gz
15 # Source0-md5:  5a26457e9f6a747896234773140a4f58
16 URL:            https://metacpan.org/dist/Crypt-Rijndael
17 BuildRequires:  perl-devel >= 1:5.8.0
18 BuildRequires:  rpm-perlprov >= 4.1-13
19 BuildRequires:  rpmbuild(macros) >= 1.745
20 %if %{with tests}
21 BuildRequires:  perl-Test-Simple >= 0.94
22 %endif
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 This module is Crypt::CBC compliant Rijndael cipher implementation.
27 Rijndael has just been selected as the Advanced Encryption Standard.
28
29 %description -l pl.UTF-8
30 Ten moduł jest zgodną z Crypt::CBC implementacją szyfru Rijndael.
31 Rijndael został niedawno wybrany jako standard zaawansowanego
32 szyfrowania (AES).
33
34 %prep
35 %setup -q -n %{pdir}-%{pnam}-%{version}
36
37 %build
38 %{__perl} Makefile.PL \
39         INSTALLDIRS=vendor
40 %{__make} \
41         CC="%{__cc}" \
42         OPTIMIZE="%{rpmcflags}"
43
44 %{?with_tests:%{__make} test}
45
46 %install
47 rm -rf $RPM_BUILD_ROOT
48
49 %{__make} install \
50         DESTDIR=$RPM_BUILD_ROOT
51
52 %clean
53 rm -rf $RPM_BUILD_ROOT
54
55 %files
56 %defattr(644,root,root,755)
57 %doc Changes NEWS README
58 %{perl_vendorarch}/Crypt/Rijndael.pm
59 %dir %{perl_vendorarch}/auto/Crypt/Rijndael
60 %attr(755,root,root) %{perl_vendorarch}/auto/Crypt/Rijndael/Rijndael.so
61 %{_mandir}/man3/Crypt::Rijndael.3*
This page took 0.043571 seconds and 2 git commands to generate.